9 Replies Latest reply: Feb 8, 2013 6:32 AM by rkaufmann87
theonlytomah Level 1 Level 1 (0 points)

I have a 2010 27" iMac just back from an Apple Authorized Service Provider. It's got a completely fresh install of OSX 10.7 but the Superdrive is acting weird.


In an attempt to install CS4 Production Premium, it failed to mount disk 1. It spins up a few times and then spits the disk out.


I tried an audio cd, and it played no problem.


I tried a regular DVD movie, and it played no problem.


Then I put in disk 2 of CS4 PP, and while it can't install or do anything without disk 1, I can hear that it makes noises like it's being read and I can see that it's recognised in Disk Utility.


I then inserted the Applications Install DVD and it wouldn't mount, spun up a few times and then spat the disk out, exactly like the CS4 PP disk 1.


All disks have been tested on another iMac running Mountain Lion and there's no problem with them.


It appears that the only disks having problems are installation disks, and to be honest, it seems more like a software/OS glitch than a problem with the actual drive.


Any help appreciated.

iMac 27" i5