7 Replies Latest reply: Feb 7, 2013 3:51 PM by New Creation
New Creation Level 1 Level 1 (0 points)

I use Scrivener's for my OSX 10.6.8.2. It requires Java. Apple has disabled Java. How do I run a safe version of Java to get my Scrivener program to work on my MacBook Pro?


iPhone 4S, iOS 5.1
  • 1. Re: Java needed to run Scrivener on OSX
    Kappy Level 10 Level 10 (226,690 points)

    If you need Java (not JavaScript which is supported) then you will have to install it on your computer. You can disable it for your browser without disabling it for another application. You just need to be aware that as long as you have Java installed you could be at risk for these various exploits.

  • 2. Re: Java needed to run Scrivener on OSX
    New Creation Level 1 Level 1 (0 points)

    Thanks for such a speedy reply. I am aware that Scrivener uses JavaScript, but ever since Apple disabled Java, I can not seem to figure out how to get the JavaScript to work with Scrivener. When I look in System Preferences there is nothing to enable. I can go to Utilities and reinstall the old Java 6 but that is the version that Apple disabled. I know how to uncheck in Safari the Java settings but I cannot figure out how to reinstall JavaScript.  Any help would be most appreciated. Thanks again for such a fast reply to my query!

  • 3. Re: Java needed to run Scrivener on OSX
    Kappy Level 10 Level 10 (226,690 points)

    It's quite possible it requires Java itself.

     

    You may want to read this article on how to enable Java.

  • 4. Re: Java needed to run Scrivener on OSX
    New Creation Level 1 Level 1 (0 points)

    Thanks so much! I am reading the article and it looks like that is exactly what I need to do.  Let me give it a shot and I will reply later with a shout out if it worked. I have already disabled the Java plugin in Safari, I just need JavaScript for Scrivener. I think this process mentioned in the article will fix the problem. Thanks again! You are providing a good service to those of us who know just enough about this to be dangerous! :-) Thanks Kappy!

  • 5. Re: Java needed to run Scrivener on OSX
    New Creation Level 1 Level 1 (0 points)

    Thanks so much! I am reading the article and it looks like that is exactly what I need to do.  Let me give it a shot and I will reply later with a shout out if it worked. I have already disabled the Java plugin in Safari, I just need JavaScript for Scrivener. I think this process mentioned in the article will fix the problem. Thanks again! You are providing a good service to those of us who know just enough about this to be dangerous! :-) Thanks Kappy!

  • 6. Re: Java needed to run Scrivener on OSX
    MrHoffman Level 6 Level 6 (12,455 points)

    Scrivener does not require Java.

     

    The documentation for Scrivener does not indicate Java is a prerequisite.

     

    I have Scrivener installed and running on a system that does not have Java installed. 

     

    Haven't exhaustively gone through all the features, but it definitely launches and works.

     

    FWIW, once you install Java, AFAIK you cannot get rid of it short of reinstalling OS X.

     

    FWIW, Javascript and Java are completely and entirely different.

  • 7. Re: Java needed to run Scrivener on OSX
    New Creation Level 1 Level 1 (0 points)

    Thanks Mr. Hoffman,

    You are right, Scrivener does not need Java to run, but it does need Java to "Compile" your file(s) and export all your footnotes, formatting etc., into Word. Everything worked beautifully until Apple disabled Java for legitimate security reasons. I emailed tech support from Scrivener and they tell me that their software runs on Java to export the file with all the necessary fonts, footnotes, formatting into Word, rtf, etc. they are working on a new update in beta that will run without Java. Until then, I need a work around. That's why this tech novice    is trying to get the best wisdom from you all. I am still processing the article that Kappy referenced to see if this will work. This is why I was wondering if I reinstalled Java and set the preferences to run only JavaScript would remedy my problem. PS, it looks like you may get buried in snow tomorrow. Stay safe and warm. And thanks for your help.