3 Replies Latest reply: Feb 9, 2013 12:04 AM by carolararipe
carolararipe Level 1 Level 1 (0 points)

Hey, guys!

 

My name is Carolina and I am from Brazil.

In January 2012 I bought my unlocked iPhone 4S on Canada's Online Apple Store and it was delivered at a friend's place, who took it to Brazil on February.

I have used my iPhone from Feb to Jan 2013 without any problem.

I moved to India last month and now I am facing a huge problem, which I have no idea how to fix.

I have got an Airtel (indian carrier) micro sim and tried it on my iPhone, but it says no service.

I have already tried to solve this problem by reseting the network settings and all settings, but none of these have worked.

Can you guys help me, please?

I brought my iPhone to India, because I paid more to buy it unlocked and it was supposed to work with all the carries from all countries, right?

 

Thank you so much in advance!


iPhone 4S, iOS 6.1
  • 1. Re: No Service Problem
    Courcoul Level 6 Level 6 (11,470 points)

    Have you tried backing it up on iTunes then erasing it to a factory-new condition prior to inserting the Airtel SIM?

     

    First try Settings / General / Reset / Erase All Contents and Settings. Else, plug into iTunes and do a Restore from the Summary tab. Be sure you have a fresh backup of all your stuff cause there will be nothing left in the phone.

     

    If this works, you can then use the backup to reload your stuff.

  • 2. Re: No Service Problem
    carolararipe Level 1 Level 1 (0 points)

    Hi, Courcoul!

     

    Thank you for your quick reply!

    I have already erased all content and settings, but it has not solved my problem.

    I will try these steps on iTunes that you have suggested me when I get home today. I hope it helps!

    I will let you know here.

    Thanks once again!

  • 3. Re: No Service Problem
    carolararipe Level 1 Level 1 (0 points)

    Hi, Corcoul!

     

    I tried to do what you have told me, but it did not work. I did a backup and restored the whole iPhone, as a brand new one. Then, I inserted the micro sim card, but it still does not recognize the Airtel sim card.

     

    Can you help me with any other solution?

     

    Thanks!