Skip navigation

Spell Check not working

14030 Views 27 Replies Latest reply: Oct 4, 2013 9:25 AM by the7thlover RSS
  • Traveling Rae Calculating status...
    Currently Being Moderated
    Mar 31, 2012 9:22 PM (in response to PeterBreis0807)

    Well excuse me for not using the correct terminology, but I did what ScottSF did: highlighted all the text in my file, went into the Inspector. Text-->More-->Language-->something other than English. My entire document became one giant red underline. I then repeated the exercise but selected English. Problem solved, no need to restart the app, play with plists, etc.

     

    TravelingRae

  • KristineMaria Calculating status...
    Currently Being Moderated
    Feb 8, 2013 3:31 AM (in response to David Robson)

    Thanks for this post!

     

    Worked perfectly for me. I'm on the latest pages 09 update through App Store and it appeared to have wiped my saved preferences for spell check and for me I had to change my preferred language to British English as it was attempting to correct all my correct British spellings as wrong!

     

    Thanks for the help though, nice and simple!

  • PeterBreis0807 Level 7 Level 7 (27,270 points)
    Currently Being Moderated
    Feb 8, 2013 4:22 AM (in response to KristineMaria)

    Amazing!!!

     

    You are all congratulating David Robson for both misunderstanding the problem and the solution and mistaking coincidentally changing the settings, whilst doing something else, as being the actual solution.

     

    Both Yvan and I explained what is going on, but you all went on blithely with the "Magic" that made it go away.

     

    Peter

  • KristineMaria Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 8, 2013 4:36 AM (in response to PeterBreis0807)

    I think you'll find he gave an accurate explanation for everyone to be able to double check their spell check preferences. We haven't asked to change the language of the computer or the document but we are trying to make sure that pages actually spell checks when we ask it to, and in the correct language.

     

    Sometimes a simple answer is all that is needed to a simple question. Maybe you could stop being annoyed that someone other than yourself gave a viable explanation to a small question and get over yourself. No one calimed it to be magic, but it has solved the problem of Pages forgetting my preset spell check preferences. Time to get off your high horse.

  • PeterBreis0807 Level 7 Level 7 (27,270 points)
    Currently Being Moderated
    Feb 8, 2013 4:47 AM (in response to KristineMaria)

    No you simply misunderstood what is going on, this has nothing to do with "double checking their language preference". That has already been set for text in your document and any text you type into it when you opened it.

     

    You have imported text from elsewhere that either has a different language or no language set as an attribute.

     

    All you had to do was Paste and Match Style to make it the same as was already in your document or just select the lot and make it the language you wanted, not switch back and forth, dangle a rabbits foot off your monitor or throw salt over your shoulder.

     

    Language is like the font, color, bold etc on your text. It just says this text is this language. Then the Mac goes ahead and spellchecks it with the correct dictionary.

     

    Thinking coincidence has meaning is no way to solve problems. Even though people do that all the time.

     

    Peter

  • KristineMaria Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 8, 2013 4:50 AM (in response to PeterBreis0807)

    And you have simply failed to read my problem. My problem for it forgetting my spell check preferences occured after an update to pages not importing text from another source. My problem was occuring with new documents that were blank that I TYPED IN MYSELF adn pages was failing to spell check, and failing to do so with the right language preference.

     

    So if you bothered to read properly maybe you realise that mine was simply to do with preferences and nothing to do with importing text from an outside source as I had simply forgottenthat I needed to right click and to use Inspector to reset those preferences.

     

    I know full well how to paste and match style thank you very much!

  • PeterBreis0807 Level 7 Level 7 (27,270 points)
    Currently Being Moderated
    Feb 8, 2013 4:55 AM (in response to KristineMaria)

    The Inspector DOES NOT change your preferences, they are whatever your System Preferences says your language is.

     

    The Inspector sets the language for selected text only.

     

    Peter

  • KristineMaria Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 8, 2013 4:58 AM (in response to PeterBreis0807)

    And you fail to understand that my SYSTEM PREFERENCES are set to BRITISH ENGLISH however pages had set itself to English eg american english which was spell checking wrong!

     

    It has been doing this in every document since the upgrade. I am not an idiot so don't treat me like one and get off your soap box!

  • PeterBreis0807 Level 7 Level 7 (27,270 points)
    Currently Being Moderated
    Feb 8, 2013 5:04 AM (in response to KristineMaria)

    Menu > Apple > System Preferences > Language & Text > Edit List… > click on British English > OK > drag British English to the top of the List

     

    You now have British English as your System dictionary. Any new documents opened in Pages will have that by default. Any existing documents will retain whatever you had it before.

     

    If you have any other problems, changing selections in Pages Text Inspector is not doing what you think it is doing.

     

    I can give up completely but you will still have the problem.

     

    Peter

  • KristineMaria Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 8, 2013 5:07 AM (in response to PeterBreis0807)

    When I say my system preferences are set to British English that means I know how to change it, it's the only language in my preferences area as it's the only language I know and I went through and deselected everything else a long time ago!

     

    I don't need a lesson from someone who has a need to prove that they're a massive geek and insufferable know it all.

     

    There is quite evidently a corruption in my pages application that I will have to work around until I have time to reinstall it.

     

    Please refrain from replying again as you're doing absolutely nothing to help me and my problem was alreayd resolved by the earlier post.

  • PeterBreis0807 Level 7 Level 7 (27,270 points)
    Currently Being Moderated
    Feb 8, 2013 5:12 AM (in response to KristineMaria)

    I give up.

     

    Peter

  • DavidRollison Calculating status...
    Currently Being Moderated
    Jun 20, 2013 8:42 AM (in response to David Robson)

    Thank you. I had this same problem. Followed your instructions. Problem solved.

  • the7thlover Calculating status...
    Currently Being Moderated
    Oct 4, 2013 9:25 AM (in response to David Robson)

    The language setting fixed it. Thanks.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.