4 Replies Latest reply: Feb 8, 2013 8:27 PM by clintonfrombirmingham
RAH97 Level 1 Level 1 (0 points)

I recently had a HDD failure on the original drive from my mid-2009 MPB.  I decided it was time to upgrade to an SSD, and purchased a Crucial 128gb (CT128M4SSD2).  I installed the drive, and initially had issues installing Mountain Lion from a USB recovery drive.  Specifically, disk utility refused to partition or erase the drive.  Crucial tech support led me to believe that the problem is that the new drive wasnt being properly initialized by the OS-less MBP, so I then placed the SSD in a USB enclosure and used my Mac Mini to successfully partition the drive.

 

Thinking there may be a problem with my MBP's SATA connection, I kept the SSD in the USB enclosure and installed Mountain Lion on it. From the USB enclosure, my MBP will boot Mountain Lion from the SSD and run without issue. However, when I re-installed the SSD internally, it refuses to boot and gives me the blank grey screen after 30-60 seconds. When I attempt to boot the recovery partition, it connects me to wi-fi, but each time I try to re-install this way, when I continue from the "to download and restore OS X, your computer's eligibility will be verified with Apple" screen, a box immediately pops up saying "An error occurred while preparing the installation. Try running this application again."

 

In short, the SSD clearly works because it will run perfectly via the USB enclosure (though at USB 2.0 speed).  My internal connection may be the problem, but it consistently recognizes the drive and partition within disk utility and as a drive selection option at startup.  Has anyone been through a similar issue when swapping out a failed HDD?


MacBook Pro (13-inch Mid 2009), OS X Mountain Lion (10.8.2)
  • 1. Re: 2009 MBP won't boot new internal SSD w/ 10.8.2 installed
    SwankPeRFection Level 4 Level 4 (1,435 points)

    I'd make sure that Crucial is on the latest firmware for it.  Other than that, there should be no issues with the Mac booting from it, but as you can tell, if it doesn't see it via the internal SATA, the problem is most likely there.  Weird thing is that even SSDs should be treated as a regular hard drive.  The Mac should have no idea that it's an SSD or not.  This is where the firmware for the drive comes into play... it's what drives (no pun intended) how the disk is detected/treated by the host machine.

  • 2. Re: 2009 MBP won't boot new internal SSD w/ 10.8.2 installed
    RAH97 Level 1 Level 1 (0 points)

    I hadn't updated the SSD firmware, but on your suggestion I tried to and learned that it was already at the latest version.  I think the problem may be the internal SATA, but the confusing part is that it recognizes the drive (as well as the recovery partition) when I start up and press Option to choose my boot drive, it just won't actually boot when I select the SSD.

     

    I'm also thinking there may be some sort of authentication or anti-piracy issue going on that won't permit the SSD to boot from the internal connection when it was initially configured via USB.  It doesn't make much sense given that both connections are to the same computer, but still.

  • 3. Re: 2009 MBP won't boot new internal SSD w/ 10.8.2 installed
    SwankPeRFection Level 4 Level 4 (1,435 points)

    I would try another recovery install on it while it's plugged into the onboard SATA.  Also, sometimes TRIM on the SSD drives can cause weird issues, especially on Macs from what I heard.  Maybe see if there's tools available to disable/enable that as a test.

  • 4. Re: 2009 MBP won't boot new internal SSD w/ 10.8.2 installed
    clintonfrombirmingham Level 7 Level 7 (28,655 points)

    Have you tried a new SATA cable - those on the 2009 models, for some reason, seem to fail using SSDs. I would bet dollars to doughnuts that's the problem.

     

    Clinton