Skip navigation

How do I fix Mingler SyncServices when it hogs memory and CPU

1220 Views 1 Reply Latest reply: Feb 8, 2013 6:52 AM by Cthulhu RSS
hugh34 Calculating status...
Currently Being Moderated
Feb 5, 2013 1:05 PM

I use iCal because it has better Google Calendar integration than Outlook for Mac.  Unfortunately it frequently consumes 100% of CPU and >5GB of memory.  I believe it is trying to resolve calendar entries but have already deleted all of my calendar profiles and re-created them.  Any other ideas?

MacBook Pro, Mac OS X (10.7.2), Mail fonts
  • Cthulhu Level 1 Level 1 (60 points)

    I found this was due to some events having dozens of alerts, which iCloud or Calendar happily added for me. I solved this by:

     

    1) Go to http://support.apple.com/kb/TS1627?viewlocale=en_US&locale=en_US and follow the instructions for your platform to reset the SyncServices folder.

     

    In my case, it was a terminal command:

     

    /System/Library/Frameworks/SyncServices.framework/Versions/A/Resources/resetsync .pl full

     

    I am not 100% sure this was required. But I did it, so I am simply telling you what worked for me. You don't lose any events or any data.

     

    2) Open Calendar and go to Preferences -> Calendar -> Alerts and make sure all the defaults are set to "None."

     

    This prevented syncing from adding alert after alert to my Google and iCloud events.

     

    Take a look at some of your events in Calendar or BusyCal or whatever, and see if you have the duplicated alert issue on some. You may have to delete some old events.

     

    3) Sync everything, and you should go good.

     

    4) Go to iTunes, and check that you are not syncing your devices both over iCloud and through iTunes.

     

    You can do this by clicking on your device and looking under the "Sync Contacts" and "Sync Calendars" under the "Info" section. Much to my dismay, SyncServices is just broken as heck, and syncing local calendars just does not work well. Apple is forcing us all into the cloud, where my personal data is now available to the masses, but that's another issue entirely and I digress.

     

    After doing these steps, I have not seen mingler or SyncServices show up as using more than a couple percent CPU for a few seconds. No more fans at maximum, no more 100% CPU.


Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.