Skip navigation

Mountain Lion no Wifi after wake from sleep

101426 Views 421 Replies Latest reply: Aug 18, 2013 8:29 AM by rgotty RSS
  • ktweddell Calculating status...
    Currently Being Moderated
    Jan 31, 2013 10:30 PM (in response to rudykho)

    I had the same problem after upgrading and tried every solution I read. Finally I went wired, then assigned a static IP to the computer on the router. So far it has worked - I have restarted a few times and it has reconnected after waking.

  • tadfromma Calculating status...
    Currently Being Moderated
    Feb 3, 2013 6:22 AM (in response to ilovecode)

    This image pretty well sums up my Mountain Lion upgrade nightmare -- I'm offered wifi on and wifi off.  Neither works.  (I had been running ML just fine, but I installed a new hard drive yesterday, booted off an old Snow Leopard CD, then downloaded a fresh copy of Mountain Lion.)  I'm now on the web via Ethernet in the TV room. 

    Screen Shot 2013-02-03 at 8.57.19 AM.png

  • tadfromma Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 3, 2013 10:44 AM (in response to ilovecode)

    My wifi is back to normal.  This is what worked for me:

     

    *Migration assistant, transferred "settings" from my Time Machine from a few days ago, before the fresh install. 
    Reboot.

    All well - so far.

     

    Tad

  • rvjacobs Calculating status...
    Currently Being Moderated
    Feb 4, 2013 11:29 AM (in response to ilovecode)

    Hello you all,

     

    I also had the problem of a disconnecting wifi while my imac was sleeping. I did not have the reconnecting issue after sleep, but the lost connection issue during sleep which made it impossible to reach my imac for things like homesharing, apple tv or remote desktop. I have a late 2012 iMac with a clean ML 10.8.2 on it and wirelessly connected to an apple time capsule (same as an airport extreme). My partner has a mid 2007 iMac, also with an ML 10.8.2 on it.

     

    I tried every single solution I could find on the internet, such as changing the router's security from wpa2 to wpa, changing the MTU from automatic to manual 1453, router reboots, re-installations, re-configurations, keychain clean-ups, everything.

     

    Eventually I solved my problem with these steps and now it works as a charm. I can still find the iMac with the remote app, even after 12 hours of sleep:

     

    My time capsule router is set on automatic MTU and encrypted with WPA2 and I use  the 5Ghz network!

    1. Cleaned all the wifi passwords in keychain on my iMac

    2. Created a new network location in system preferences

    3. In this location I deleted the bluetooth pan and bluetooth dun connection.

    4. In this location I changed the preferred connection-order to wifi on #1 and ethernet on #2.

    5. Restarted my iMac.

     

    Now I still have a connection when it sleeps and I can wake it to low profile using the remote app (homesharing) and everything works fine.

     

    Hope more people wille be helped by this.

  • ChazThePhoenix Level 1 Level 1 (10 points)
    Currently Being Moderated
    Feb 8, 2013 7:44 AM (in response to rvjacobs)

    I have been monitoring and trying every fix in this thread for weeks.

     

    I am on a 27' iMac at work....IT/Network guys have no clue what causes my freezing, so I am left to find myself

     

    I was sitting here reading this thread, minding my onw busines...with the concsole up on the side and I noticed this......something about core services.

     

    I was touching nothing...maybe scolling trackpad mouse ocassionally

     

     

     

    2/8/13 9:37:07.592 AM com.apple.launchd[1]: (com.aladdin.hasplmd) Throttling respawn: Will start in 10 seconds

    2/8/13 9:37:07.603 AM ReportCrash[1707]: Saved crash report for hasplmd[1710] version ??? to /Library/Logs/DiagnosticReports/hasplmd_2013-02-08-093707_MDC02G56JTDHJQ.crash

    2/8/13 9:37:17.624 AM ReportCrash[1707]: failed looking up LS service ( scCreateSystemService returned MACH_PORT_NULL, called from SetupCoreApplicationServicesCommunicationPort, so using client-side NULL calls.

    2/8/13 9:37:17.624 AM ReportCrash[1707]: LaunchServices/5123589: Unable to lookup coreservices session port for session 0x186a0 uid=0 euid=0

    2/8/13 9:37:17.624 AM ReportCrash[1707]: failed looking up LS service ( scCreateSystemService returned MACH_PORT_NULL, called from SetupCoreApplicationServicesCommunicationPort, so using client-side NULL calls.

    2/8/13 9:37:17.624 AM ReportCrash[1707]: LaunchServices/5123589: Unable to lookup coreservices session port for session 0x186a0 uid=0 euid=0

    2/8/13 9:37:17.624 AM ReportCrash[1707]: failed looking up LS service ( scCreateSystemService returned MACH_PORT_NULL, called from SetupCoreApplicationServicesCommunicationPort, so using client-side NULL calls.

    2/8/13 9:37:17.624 AM ReportCrash[1707]: LaunchServices/5123589: Unable to lookup coreservices session port for session 0x186a0 uid=0 euid=0

    2/8/13 9:37:17.624 AM ReportCrash[1707]: failed looking up LS service ( scCreateSystemService returned MACH_PORT_NULL, called from SetupCoreApplicationServicesCommunicationPort, so using client-side NULL calls.

    2/8/13 9:37:17.624 AM ReportCrash[1707]: LaunchServices/5123589: Unable to lookup coreservices session port for session 0x186a0 uid=0 euid=0

    2/8/13 9:37:17.624 AM ReportCrash[1707]: failed looking up LS service ( scCreateSystemService returned MACH_PORT_NULL, called from SetupCoreApplicationServicesCommunicationPort, so using client-side NULL calls.

    2/8/13 9:37:17.624 AM ReportCrash[1707]: LaunchServices/5123589: Unable to lookup coreservices session port for session 0x186a0 uid=0 euid=0

     

     

     

    I have wifi off.

     

    cant turn off bluetooth because of mouse

     

    JUST rmoved all unnecessary tool bar things

     

    but the core services concerns me. What is THAT all about?

     

    I am going to try the "disable screen saver" and "do not put the computer to sleep" option next.  That will be monday as I shut it down on weekends

     

    Chaz

  • Sandman Level 4 Level 4 (3,270 points)
    Currently Being Moderated
    Mar 18, 2013 5:25 PM (in response to ilovecode)

    I'm sure you will all love to here this...

     

    but my brand spanking new 27 inch (i7) iMac.. totally fresh installation with no "baggage" (never been connected to another network, no fancy utilities, etc).. loses the wifi connection during sleep and takes at least 15-20 seconds to reconnect when it wakes.

     

    A little frustrating and pretty much defeats the purpose of instant on with a home machine.

     

    I have a dualband Airport extreme. Also, my 24 inch iMac has no delay after waking from sleep.

  • andylepandy Calculating status...
    Currently Being Moderated
    Mar 18, 2013 5:31 PM (in response to Sandman)

    Well count yourself lucky you arent losing all wifi hardware use at all, the other day I was travelling away from home and an hour before my international flight my MacBook crapped out after the wifi hardware stopped responding, I had to completely wipe my hard drive and do a fresh install of OSX Mountain Lion. Please, dont complain about a 15-20 second wipe when some of us actually go days if not weeks with out a wifi connection...

  • WildBill Level 3 Level 3 (530 points)
    Currently Being Moderated
    Mar 18, 2013 5:53 PM (in response to Sandman)

    Sandman,

    Amazed this thread is still active! Somewhere many pages back I supplied my own comments and what resolved this issue for me. After trying all the fixes (at the time), I decided out of desperation to replace my nearly seven year old AEBS. Miraculously, that seemed to fix my problem! Unfortunately, that's all I have to offer you. 

  • peterwillem Level 1 Level 1 (10 points)
    Currently Being Moderated
    Mar 19, 2013 1:33 AM (in response to WildBill)

    So did I. But really it is not that surprising. Apple's new OS (ML) and IOS(6.xx) causes that many users experience lots of wifi or wifi related problems. Read the relevant threads on these issues  on this forum.

    Apple software is not that reliable anymore.

    I "solved" mine  with  ML on my iMac by using a cable connection to the internet (switched off wifi), and with my iPad and iPhone by not updating to IOS 6 (using IOS 5.1.1)

     

     

    peterwillem

  • WildBill Level 3 Level 3 (530 points)
    Currently Being Moderated
    Mar 19, 2013 6:25 AM (in response to peterwillem)

    What I find even more troubling is that despite a thread like this of twenty six pages Apple does not appear to have made an effort to fix the glitches in their software! Or at least address the issue in their knowledge base and offer some workarounds. It makes you wonder if Apple is even aware of this problem, but how, in all honesty, can that be?  

  • peterwillem Level 1 Level 1 (10 points)
    Currently Being Moderated
    Mar 19, 2013 7:50 AM (in response to WildBill)

    I find that troubling too.I suspect that Apple has its own agenda on this.What that is we can only speculate about and that won't get us very far. There is not much we can do about this, and they know that.

    Only thing to do is abide our time and wait for a sofware update that will solve these issues.

    Will probably take a long time.

  • Herbert Schulz Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 19, 2013 8:01 AM (in response to peterwillem)

    Howdy,

     

    Strangely I switched from WiFi to direct Ethernet Cable connection to my Gen 1 Time Capsule (latest software) when I had problems under OS X 10.7. That ``fixed'' my problem; I don't consider that a fix but rather a ``work around''.

     

    Unfortunately, when I updated to OS X 10.8 my direct connection would sometimes not reconnect and I'd end up with a default IP address so my actually connection was dead. I can force a reconnect by going to System Preferences->Network, make the Ethernet connection Inactive (the gear menu), Apply that, make the Ethernet connection Active (the gear menu), Apply that and then the connection would come back.

     

    So the problem isn't only with WiFi!!!

     

    Good Luck,

    Herb Schulz

  • Andrew Harris1 Calculating status...
    Currently Being Moderated
    Mar 19, 2013 8:07 AM (in response to ilovecode)

    I thought I had the problem that people here are reporting but it turns out my issue is slightly different and I found a solution. I'll post it here in case it helps someone.

     

    My issue:

    After a long sleep items in my toolbar stop responding (wi-fi audio etc.) and I can't open applications. Evenually everything crashes and i have to restart.

     

    Cause:

    I have a western digital drive and at some point I installed the software. I had problems with the software and uninstalled it or I thought I did. Turns out I had some WD stuff running in the background. I had to use the command line to remove them. Problem solved.

     

    TL;DR Don't ever install western digital software.... it's like a virus.

     

    Note: If you want to narow down the wifi problem you are all having you should post detail about your set up so you can find some commonalities.

     

    Note2: I think the wifi problem has something to do with power nap. 

     

    Note3: You can get wifi debug information by holding option clicking on the wifi icon and selecting "Open wifi diagnostics" turn on debug logs and post the log when you have the issue.

  • Andrew Harris1 Level 1 Level 1 (90 points)
    Currently Being Moderated
    Mar 19, 2013 8:09 AM (in response to Andrew Harris1)

    Oh btw there is a system update today 10.8.3

  • vallejogreg Calculating status...
    Currently Being Moderated
    Mar 19, 2013 11:30 AM (in response to ilovecode)

    Turn off "wake for network access" in the energy saving section of preferences, or change energy saver prefs to "never sleep". 

    Or upgrade all devices so that they are "wake on demand" also known as "Bonjour Sleep Proxy" capable.  This includes router, apple TV, maybe even printer.

     

    Apple took to big of a step forward in it's "Airplay" concept.  This is my opinion, I am pretty sure the problem is in this Bonjour Sleep Proxy business.  What they did sounded easy, but it's not. 

     

    the fact that devices are now required to go into low power mode after a period of non-use really threw a monkey wrench into Apples attempt to implement "wake on demand".

     

    This all started with Snow Leopard - which had the first iteration of Bonjour.  If what I suspect is the case, for Airplay to work, you need Bonjour Sleep Proxy capable devices - probably nothing made before 2008 or maybe even 2010

Actions

More Like This

  • Retrieving data ...

Bookmarked By (23)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.