Skip navigation

Unable to export iPhoto

4830 Views 18 Replies Latest reply: Feb 8, 2013 11:37 AM by Old Toad RSS
  • limeychiney Calculating status...
    Currently Being Moderated
    Jul 9, 2011 11:10 AM (in response to Terence Devlin)

    TD, I tried sending you an email at Slam10 at mac.com and got this:

     

    Hi. This is the qmail-send program at yahoo.com.

    I'm afraid I wasn't able to deliver your message to the following addresses.

    This is a permanent error; I've given up. Sorry it didn't work out.

     

    <slam10@mac.com>:

    17.148.17.46 does not like recipient.

    Remote host said: 550 5.1.1 unknown or illegal alias: slam10@mac.com

    Giving up on 17.148.17.46.

     

     

    Let me know if I'm doing something wrong.

  • Rui Covelo Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 8, 2013 10:04 AM (in response to Kristina Latour)

    Hi!

     

    I found this thread because I was getting the same message. Following the tip "Show file" I got watch the files a little bit closely and found the solution to my problem. I will leave it here even if my configuration is not the most common.

     

    In order for my girlfriend to access the same pictures I do (we share the same MacBook), I moved my iPhoto Library to a shared folder and changed the file permissions so we both could read and write to the same library. It turns out I probably forgot to change the permissions on some of the files or new files created after the initial configuration got created with different permissions. With "show file" I was able to access the photos in Finder and "correct" the permissions.

     

    I will now review this configuration because it might not be the best solution to share the library (read and write) with my girlfriend.

  • Terence Devlin Level 10 Level 10 (121,650 points)
    Currently Being Moderated
    Feb 8, 2013 11:36 AM (in response to Rui Covelo)

    To correct permissions in an iPhoto Library

     

    Back Up and try rebuild the library: hold down the command and option (or alt) keys while launching iPhoto. Use the resulting dialogue to rebuild. Note the option to check and repair library permissions.

     

    For best results: use an external disk formatted Mac OS Extended (Journaled) and set to ignore permissions.

  • Old Toad Level 10 Level 10 (113,060 points)
    Currently Being Moderated
    Feb 8, 2013 11:37 AM (in response to Kristina Latour)

    Go into your System/Energy Saver preference pane and set Computer Sleep and Display Sleep to never.  Then try exporting the slideshow as a QT movie again.  If that doesn't help continue with this:  make a temporary, backup copy of your library if you don't already have one (Control-click on the library and select Duplicate from the contextual menu) and  apply the two fixes below in order as needed:

     

    Fix #1

     

    Launch iPhoto with the Command+Option keys held down and rebuild the library.

     

    iPhotorebuild.PNG

     

    Select the options identified in the screenshot

     

    Fix #2

     

    Using iPhoto Library Manager  to Rebuild Your iPhoto Library

     

      1. Download iPhoto Library Manager and launch.
      2. Click on the Add Library button, navigate to your Home/Pictures folder and select your iPhoto Library folder.
      3. Now that the library is listed in the left hand pane of iPLM, click on your library and go to the File ➙ Rebuild Library menu option
      4. In the next  window name the new library and select the location you want it to be placed.
      5. Click on the Create button.

     

    Note: This creates a new library based on the LIbraryData.xml file in the library and will recover Events, Albums, keywords, titles and comments but not books, calendars or slideshows. The original library will be left untouched for further attempts at fixing the problem or in case the rebuilt library is not satisfactory.

     

     

    OT

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.