3 Replies Latest reply: Feb 14, 2013 9:28 PM by kanotna
SteveG10 Level 1 Level 1 (0 points)

Older iMac(2004) - OSX 10.4.11, can't upgrade anymore, TurboTax 2008-11 worked fine, now TurboTax 2012 is incompatible

 

Looking for options - short of a new computer


iMac, Mac OS X (10.4.11)
  • 1. Re: Looking for options:  Older iMac - OSX 10.4, can't upgrade anymore, TurboTax 2008-11 worked fine, now TurboTax 2012 is incompatible
    rccharles Level 5 Level 5 (5,350 points)

    They require a newer computer.

    Processor:

    Intel-based Processor

    Operating System:

    Mac OS X v10.6.8 or later

    Mac OS X v10.7.5 or later

    Mac OS X v10.8.0 or later

    Note: 64-bit required for Mac OS 10.6.8

     

    Heard that there is a web browser version.  Perhaps you could use that.

     

    --------------------

    Here is a port of the latest firefox browser.

     

     

    for PPC

    tenfourfox -- It's a port of the latest FireFox to run on older hardware and software.

    "World's most advanced web browser. Finely tuned for the Power PC."

    http://www.floodgap.com/software/tenfourfox/

    alternative download site:

    http://www.macupdate.com/app/mac/37761/tenfourfox

  • 2. Re: Looking for options:  Older iMac - OSX 10.4, can't upgrade anymore, TurboTax 2008-11 worked fine, now TurboTax 2012 is incompatible
    Allan Jones Level 7 Level 7 (30,415 points)

    I know you don't want to hear this, but we replaced a G3 iMac in 2006 and a perfectly good eMac 1.42Ghz last December partly because of the TurboTax issues.

     

    To their credit, they did maintain PPC compatibility about two years longer than I expected considering the last PPC Macs were made in early 2006.

  • 3. Re: Looking for options:  Older iMac - OSX 10.4, can't upgrade anymore, TurboTax 2008-11 worked fine, now TurboTax 2012 is incompatible
    kanotna Level 1 Level 1 (0 points)

    I'm in the exact same situation.  I have the last of the pre-intel Imac G5s, running 10.4.11. I like this setup because it allows classic mode for older software (bought my first Mac in 1985).  I've used Turbo Tax every year since 2005 and bought the 2012 Premier at Sam's Club without reading the fine print.  Never dreamed they'd revise their product to eliminate us from their customer base.  For what it's worth, I called their tech support people today.  They assured me I could still file on line, but after over an hour of trying to walk me through, they finally gave up and told me I'd have to upgrade my software.  By "they" I mean the lady helping me and several of her superiors. The plan was to give me a credit to offset the on-line filing cost, but when it wouldn't work, no offer of refund.  "Sorry we couldn't help you sir."

     

    After reading numerous posts on this subject I now realize a central issue is that you have to have a 64-bit Mac to load 10.6.8 or later.  I believe all pre intel imacs (and a couple of intels) are 32 bit. Essentially, Turbo Tax is telling us to buy a new computer.  We can't upgrade to the software they require.  

     

    A turbo tax rep has responded to numerous posts and maintains they value Mac customers and just had to do this to keep current.  They just had to discard a small percentage of mac customers. I'm not tech savvy enough to challenge that, but it has always irked me that, as a small business owner, Turbo Tax has never made their Business software package available to Mac users.  And, when I called today, the lady said they were overwhelmed by the number of mac users in the same boat.  So maybe the number isn't so small.  They won't admit it, but they've made a huge mistake that will cost them a tremendous amount of good will.