Skip navigation

Wi-Fi Connected, but no internet access

365960 Views 91 Replies Latest reply: Apr 17, 2014 7:25 AM by Kashish Nada RSS
  • KrisAngela Calculating status...
    Currently Being Moderated
    Aug 21, 2012 7:27 PM (in response to JF87)

    i am also having trouble with my wifi connection (ipod 4g). it has been three or five days since the last time i connected my ipod with wifi. it always says: "Safari cannot open the page because it is not connected to the Internet"), even though the Wifi icon in the top left corner still shows full signal. However, I noticed when I went into Wifi settings (Settings>Wifi) that there is no checkmark next to my network name (only the spinning circle icon, as if it's trying to process something). this happens to ALL wifi networks available. TRIED ALL THE SOLUTIONS SUCH AS RESETTING, RESTORING, AND FORGETTING THE NETWORK. WHAT IS THE BEST WAY TO BRING BACK THE USE OF MY WIFI ON MY IPOD? PLEASE? TY

  • KrisAngela Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 25, 2012 10:06 AM (in response to KrisAngela)

    ARE THERE NO SOLUTIONS FOR THIIIIIIIIIIIIIIIIIS?? IT HAS BEEN A WEEK SINCE I USED WIFI ON MY IPOD. IT REALLY DISAPPOINTS ME YOU KNOW! TRIED ALL OF TH EPOSSIBLE SOLUTIONS GIVEN HERE.

  • Fulblade Calculating status...
    Currently Being Moderated
    Aug 25, 2012 6:18 PM (in response to Kristopherk07)

    My software firewall was blocking the connection. My company installs a software firewall security package and it was denying the connections from my iPhone. I had to permit the ip address that the hotspot network was trying to use and everything started working.

     

    You can check for udp connections being blocked from svchost and see which ip needs to be permitted. I added it to my allowed ips and everything started working.

     

    Hope that helps.

  • Tische Calculating status...
    Currently Being Moderated
    Aug 30, 2012 3:52 PM (in response to Kristopherk07)

    Iphone 4S: I went to Itunes, made a backup (right clicking in the iphone device name: backup) and began a "Restore"under "Version" in the main screen. Immediately Internet was restored. I cancelled "Restore". It is working since...

  • Nakul.13 Calculating status...
    Currently Being Moderated
    Sep 4, 2012 11:41 PM (in response to Kristopherk07)

    None of the solutions worked for me and I had given up until I tried something on my own and IT WORKED
    Ok here is what I did -

     

    1. Reset My router, changed my wifi name and password. (Don't forget to RENAME it)

     

    2. Turned on wifi on 4S.

     

    3. I had to enter all the settings in "STATIC" (IP address, subnet mask, router, DNS)

     

    4. VOILA, it starts working again.

     

    Strange bug but this has fixed it for the moment.

     

    Hope it works for you all as well. cheers!!

  • Jenhough Calculating status...
    Currently Being Moderated
    Sep 10, 2012 8:35 PM (in response to JF87)

    Did you find a solution? I have this problem too.

    So frustrating!!

  • Reece 123456 Calculating status...
    Currently Being Moderated
    Sep 29, 2012 4:41 AM (in response to Kristopherk07)

    I just fixed mine. Do this

     

    Go to wifi

    Find your wifi connection and select the arrow ( blue on right of screen)

    Select renew lease

    Enter apple id pass word

     

    Fixed

  • Noypi_Ako Calculating status...
    Currently Being Moderated
    Sep 29, 2012 9:55 AM (in response to Kristopherk07)

    Fix Mine!

     

    PC w/ Win 7

    Ipad 2

    D-Link DIR-615 Version C1 Firmware 3.11NA ROUTER

     

    Problems:

     

    1. Can surf thru Safari in less than 5 minutes and then drops

    2. When I try to go to App Store in less than a minute wifi drops

    3. When I watch Youtube, the video stops downloading halfway because wifi drops

     

    I am having this problem since I installed IOS6 last Monday the 24th of September.

     

    SOLUTION:

     

     

    RE-CONFIGURE ROUTER

     

    1.  On wireless settings under Setup tab:

       a.  disable auto channel scan

       b.  change chanel to 11

       c. rename SSID

     

    2. On Firewall Settings under Advance Tab:

        a. enable DMZ (Demilitarized Zone)

        b. Input the DMZ ip address of the Ipad (ipad must be using static ip address)

     

    Put Wifi to Static

     

    1. When you are connected with you wifi, click on the blue arrow on the wifi's name

    2. Copy all the settings of the DHCP to the Static

    3. Copy the IP Address and input it on Routers DMZ

     

    hope this will help....

     

    we have different routers. dmz's function is just to set a computer OUTSIDE of the router for unrestricted internet connection... if you have feature on your router then try to set your ipad on this...

     

    Hope this helps....MABUHAY!!!!!

  • akire_cap15 Calculating status...
    Currently Being Moderated
    Dec 3, 2012 7:23 AM (in response to Kristopherk07)

    hi, i have iPhone 3Gs and 4s that perfectly connecting to my ad hoc network using my Sony Vaio windows 7, my prob my other iPhone 4 and my iPad 2 cant connect, they can detect my wifi but everytime i tried to connect the wifi signal didnt show, i tried to change from DHCP to static and change the IP Address to 192.186.10.56 with subnet mask 255.255.255.0 i managed to get the wifi bar but when i browse the net its says " no internet connection".

     

    please help me with this, my friends 3Gs also work and able to connect in my ad hoc network but this iphone 4 with oversea simcard and ipad without simcard can't connect. Thanks.

  • AnatS Calculating status...
    Currently Being Moderated
    Feb 8, 2013 11:16 PM (in response to Kristopherk07)

    I had the same problem but my boyfriend just solved it.

    Basically, he just reassigned the ip address for the device.

    Go to the wifi setting for the network you're connected to. Change to Static and manually input the addresses. If you have a PC connected to the network, go to run>cmd>ipconfig to get the addresses.

    These are the same addresses you automatically get under DHCP setting and you should keep the numbers all the same except the IP Address. It should be 192.168.1.x change the x to any number that's not assigned to any other device in your network (just choose a high number).

    Before:

    IP Address: 192.168.1.7

    Subnet Mask: 255.255.255.0

    Router Address: 192.168.1.1

    DNS: 192.168.1.1

    After:

    IP Adress: 192.168.1.8

    Everything else the same.

     

    There could be other causes to this problem but I hope this helps some of you.

  • Gomez_Addams Calculating status...
    Currently Being Moderated
    Feb 26, 2013 12:33 PM (in response to Kristopherk07)

    I solved by using "mHotspot" free third party software.  "Connectivity" also worked, but was shareware with ads.  I tried all of the other suggestions on here to get an adhoc connection to work to no avail.

     

    Windows 7 laptop with ethernet internet connection.

    iPod 5G

  • BoulPa Calculating status...
    Currently Being Moderated
    Feb 26, 2013 1:47 PM (in response to AnatS)

    Dear AnatS

     

    Thanks for your advice as this has fixed the problem I had with my iPad2 not connecting to the internet... your recommendation above is greatly appreciated...

  • hugh mcatamney dit Calculating status...
    Currently Being Moderated
    Mar 22, 2013 11:18 AM (in response to eureka204)

    4.2.2.4

     

    did the trick!

     

    Why is that?

  • Ferenc30 Calculating status...
    Currently Being Moderated
    Apr 13, 2013 6:42 PM (in response to eureka204)

    This seemed to work for me aswell, Thank you very much!

  • isaacberman Calculating status...
    Currently Being Moderated
    Apr 24, 2013 8:13 AM (in response to eureka204)

    this worked on my 4s! thanks!

1 ... 3 4 5 6 7 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.