Skip navigation

Changing the language of the Pages spelling checker doesn't work.

776 Views 5 Replies Latest reply: Feb 9, 2013 6:42 AM by PeterBreis0807 RSS
-deZeeuw Calculating status...
Currently Being Moderated
Dec 2, 2011 6:32 AM

Hi there,

 

I changed my settings in System Preferences and Pages itself. When I changed the Pages settings it just turned back from Dutch (the language I want to set my spelling checker to) to English. It's just really annoying to see my whole document filled with red underlining and obviously to not have a proper working spelling checker.

 

Please help.

Pages, Mac OS X (10.7.2)
  • PeterBreis0807 Level 7 Level 7 (27,340 points)


    -deZeeuw wrote:

     

    Hi there,

     

    I changed my settings in System Preferences and Pages itself.

     

    To what? Dutch or English? Have you dragged Dutch/English to the top of the list to make it the default?

    When I changed the Pages settings it just turned back from Dutch (the language I want to set my spelling checker to) to English. It's just really annoying to see my whole document filled with red underlining and obviously to not have a proper working spelling checker.

     

    Have you checked what the language that you selected was set to:

     

    Inspector > Text > More > Language: Nederlands

     

    It will stick with the default language, unless you change it to something else. The language is part of the text style like, bold, italic or the font. You may need to update your styles to match your intended language.

     

    Peter

  • Level 8 Level 8 (41,760 points)

    In a document, the language used by the spell checker is defined from the Inspector of text.

    If you select a piece of text which is treated as English then open this Inspector, I guess that you will see that the selected language is English.

     

    2011-12-02T16.25.59.jpg

    Select the entire document then select Dutch.

    As far as I know, Pages is unaware of the selection which you made from the System PrefPane.

    2011-12-02T16.30.37.jpg

    This System feature was introduced in mac OS X 10.6 but iWork was designed for 10.5.

    We have to wait for the next upgrade to get iWork applications aware of the features available in this System Preference pane (the Text page).

     

    Yvan KOENIG (VALLAURIS, France)  vendredi 2 janvier 2011 16:34:54

    iMac 21”5, i7, 2.8 GHz, 4 Gbytes, 1 Tbytes, mac OS X 10.6.8 and 10.7.2

    My iDisk is : <http://public.me.com/koenigyvan>


    Please : Search for questions similar to your own before submitting them to the community

     

     

  • Cattus Thraex Level 4 Level 4 (1,715 points)

    Pages does not follow the spell check settings in System Preferences, so you must select them within Pages, independently of what you select in sys prefs.

    For the time being, Mac OS X, Lion included, has a quite complicated spell check selection in case of multinational texts, in which 2-3 languages are used. I could do that for Nisus, with the help of Martin Wierschlin, but otherwise it is quite cumbersone.

    Yvan Koenig commented the rest. Screen Shot 2011-12-02 at 22.10.43.png

  • Briolet Level 1 Level 1 (5 points)

    Thanks for clearing this up. Because the spelling settings are so different than other mac applications, I didn't even think of looking there. The two solutions I used until now were:

     

    - Temporary setting the system language to English when writing english letters.

    - Writing the letter in textedit and than paste the corrected text into Pages.

     

    No Idea why I never noticed this language setting between the options. And I must admit that it has its charmes being able to set it for multilingual texts this way.

  • PeterBreis0807 Level 7 Level 7 (27,340 points)

    The Language Settings are defined by the system and are not different in Pages.

     

    All that Pages does is let you redefine the language of selected text using the Text Inspector.

     

    What it is doing is tagging that selected text and saying this text is that language, use the appropriate spell checker.

     

    As an attribute of the Text you can save a Paragraph Style/s of the text in the Styles Drawer, tagging it (Eng) or whatever and apply that to the English text as you need it.

     

    Peter

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.