Skip navigation

Problems using my new iPod classic, says it requires iTunes version 10.7!

421 Views 1 Reply Latest reply: Feb 9, 2013 6:42 PM by mdk90274 RSS
UR2SLO Calculating status...
Currently Being Moderated
Feb 9, 2013 3:32 AM

I've just bought an iPod classic to store my music collection, but it says it can't be used because it requires iTunes version 10.7 or later. (I'm currently running iTunes version 10.6.3) I can't download iTunes version 10.7 because my iMac is running on OS X version 10.5.8. I hadn't anticpated this problem as the iPod classic is a relatively old model, not updated since 2009. I didn't really want to buy new operating software for my Mac as well. Any ideas what to do please?

iPod classic, Mac OS X (10.5.8)


More Like This

  • Retrieving data ...

Bookmarked By (1)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.