Skip navigation

No sound, loudspeakers greyed out, muted

1337 Views 8 Replies Latest reply: Feb 14, 2013 10:35 PM by felmyr RSS
felmyr Calculating status...
Currently Being Moderated
Feb 9, 2013 5:15 AM

Hi i ve a mid 2010 MacBook Pro


and since recently the issues amount.

I cannot hear any sound anymore and if looking into the preferences, it appears muted is ticked but i cannot untick it.


This applies to all internal speakers and the headphone jack while using a USB headphone works.

There is no red light in the headphone jack on so i ve no idea what to do to fix it.


Since i updated to lion years ago i also lost functionality of my dvd drive.


This is my last mac as with windows i can at least fix those issues or get inexpensive help. WIth mac it all comes for a top of the range premium.


Anyone able to help me to use my headphones again??


Thanks a million

MacBook Pro, OS X Mountain Lion (10.8.2)
  • Shootist007 Level 6 Level 6 (16,640 points)
    Currently Being Moderated
    Feb 9, 2013 5:22 AM (in response to felmyr)

    Have you tried disconnecting the USB headphones? Could be they are controlling the system for sound output to the USB port.




    My current MBP and iPod will be the last Apple devices I ever buy.


    Good Luck and Best Wishes.

  • OGELTHORPE Level 7 Level 7 (22,375 points)
    Currently Being Moderated
    Feb 9, 2013 5:26 AM (in response to felmyr)

    Try a PRAM reset:




  • dominic23 Level 6 Level 6 (18,350 points)
    Currently Being Moderated
    Feb 9, 2013 9:49 AM (in response to felmyr)

    Reset SMC.


    Choose the method for:

    "Resetting SMC on portables with a battery you should not remove on your own".


    Applications/Utilities/ Audio MIDI


    Audio Devices window

    Side Bar

    Click the Built-in Output.


    Under Mute any box checked? If so, uncheck it.



  • RedCandy247 Calculating status...
    Currently Being Moderated
    Feb 9, 2013 12:23 PM (in response to felmyr)

    I just had this happen out of the blue on my one month old 13" MBPRetina. I researched everything on here and the internet and then it occurred to me to try an old PC trick, which is restart the computer (I usually put it to sleep) to reload drivers and it fixed it for me...don't know if this will help anyone else but good luck.

  • exNewt Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 12, 2013 12:14 PM (in response to felmyr)

    Manually deleted old files likes ones below from


    Library > Preferences > Audio  (these were outdated - spread the word!)


    Library > QuickTIme











    FCP Uncompressed 422.component

    Google Camera Adapter 0.component

    Google Camera Adapter 1.component









    Sound works on 15" MBP from 2010 !!!!


More Like This

  • Retrieving data ...

Related Articles

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.