Skip navigation

Final Cut Pro 5 on Snow Leopard

1524 Views 8 Replies Latest reply: Feb 9, 2013 6:50 AM by Michael Grenadier RSS
xKiYoMiNaTiONx Calculating status...
Currently Being Moderated
Feb 8, 2013 5:02 AM



I'm really not sure if this has been answered by others, but so far, everywhere I look I'm either not seeing the answer I want, or it's a different platform. I have a MacBook (Aluminum, Late 2008) Model. It originally came with 10.5 (Leopard). However, recently, I'm not too sure how long ago, I upgraded my Leopard to a Snow Leopard because there were some things that weren't working on 10.5.8 anymore. But now, my old faithful, my Final Cut Pro 5.1.4 (Academic Ver.) no longer works right =( I can still open the application and I can also play my rendered files. However, when I want to edit my clips in the slug, the audio plays, but the video doesn't. I've tried many things already, and I already have all the codecs that I need for the application to work. Unless, having 10.6.8, screws things up? Is it really true that I can't use my Final Cut on Snow Leopard now? (From all the posts that I have seen.). I really do not want to part with this program, also mainly due to the fact I have no money, and I am comfortable with the program.


But the thing that is really weird is that my sister had a MacBook Pro that came with Snow Leopard already, she installed FCP 5 on her computer and it works fine. So how come it won't work on my computer? Is it because I only have a MacBook and not a Pro?


Your feedback would be most appreciative. Thank You.

Mac OS X (10.5.8)
  • Christoph Vonrhein Calculating status...
    Currently Being Moderated
    Feb 8, 2013 12:32 PM (in response to xKiYoMiNaTiONx)

    FCP 5 should work just fine on your MacBook.


    There are a few things you can try:


    - Trash your prefs and repair your disk permissions. There are several web-pages on the net that tell you how to do it. It's very simple in the end.


    - Reinstall FCP. It is possible that the upgrade to 10.6 "screwed up" you FCP installation. FCP consists of many files on your hard drive and if only one (or a few) get corrupted then you will see such things happen.

  • Russ H Level 6 Level 6 (12,945 points)
    Currently Being Moderated
    Feb 8, 2013 1:46 PM (in response to xKiYoMiNaTiONx)

    How did you install it? Perhaps a required QuickTime or Pro update is missing. Ideally, one installs from the installation disk and then run Software Update until there are no longer any available, repair permissions and start editing. I assume that you can get what you need from Software Updates, but have no way of verifying.


    If you reinstall, use Digital Rebellion's FCS Remover to may sure that you delete all the many files that Christoph refers to.


    Good luck.



  • Russ H Level 6 Level 6 (12,945 points)
    Currently Being Moderated
    Feb 8, 2013 2:10 PM (in response to Russ H)

    I guess the way I'd do it is select one of the composited clips; in the Inspector > Compositing, hit the re-set arrow (the curved arrow). Copy that clip. Then select  all the ones you want to rest and Edit> Paste Attributes>Compositing.


    There may be a faster way and perhaps someone will chime in with that.



  • SoCal Level 4 Level 4 (1,255 points)
    Currently Being Moderated
    Feb 8, 2013 9:56 PM (in response to xKiYoMiNaTiONx)

    DON't USE H.264!!!!!!!!  It's not an editing codec.  Use MPEG Steamclip to convert your files to an editing codec.

  • Russ H Level 6 Level 6 (12,945 points)
    Currently Being Moderated
    Feb 9, 2013 6:22 AM (in response to xKiYoMiNaTiONx)

    If you thought my second reply was more than a bit off target, you're right!


    I was responding to another person's issue and had too many tabs open at once.


    Sorry for the confusion.




    Also…totally agree with SoCal. It may look like things are working OK, but chances are that h.264 will cause grief somewhere along the way.

  • Michael Grenadier Level 6 Level 6 (19,805 points)
    Currently Being Moderated
    Feb 9, 2013 6:50 AM (in response to xKiYoMiNaTiONx)

    it's not safe to work with h264 in fcp.  Eventually things will stop working. 


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.