13 Replies Latest reply: Feb 10, 2013 6:56 PM by BDAqua
Server rookie Level 1 Level 1 (40 points)

Hi there, I have the HD of my old G4 Quicksilver hooked up to a Wiebetech Ultradock 5 and a G5 1.8 DP, both are hooked up to an i7 MBP running 10.7.5.

Now I want to clone the old HD to the HD of the G5 that's in target mode. I've cloned with CCC 3.4.7 but after cloning the G5 doesn't show up as bootable disk in the sys prefs. Since it's a G5 I also cloned the OS9.2.2 system and blessed the Finder but that one isn't seen as well. What am I missing? TIA

  • 1. Re: Clone 10.4.11 to empty HD
    BDAqua Level 10 Level 10 (116,480 points)

    Hello,

     

    Where does the MBP come into the picture? Was it used for cloning somehow? Or was the G4 used?

     

    Does the G5 boot normally to clone itself?

  • 2. Re: Clone 10.4.11 to empty HD
    BDAqua Level 10 Level 10 (116,480 points)

    Oh, what Interface is the Ultradock using? What Mac are you not seeing it as a boot choice on?

  • 3. Re: Clone 10.4.11 to empty HD
    Server rookie Level 1 Level 1 (40 points)

    Hi BD Aqua,  here's the setup.

    The Ultradock has 2 FW800 ports, one goes to the MBP with CCC, the other to the G5 (in target mode).

    So on the MBP both disks are visible.

    In CCC I choose the old drive as source and the G5 as destination.

    Then start the clone process.

    After cloning I get a diolog saying the clone was successful.

     

    Then I disconnect both drives from the MBP. Power down the Ultradock and disconnect the G5.

    Then boot the G5 that now holds OS 10.4.11. But the G5 doesn't see it's installed system.

     

    It's obvious that the MBP doesn't accept 10.4.11 (i.e. see it as startup disk in its sys prefs) as it is an Intel machine.

    But the G5 should be fine.

    In the clone is also the classic mode (OS9.2.2) on which I blessed the Finder which should make it bootable

    but that also doesn't work.

     

    So, what's going on?

  • 4. Re: Clone 10.4.11 to empty HD
    BDAqua Level 10 Level 10 (116,480 points)

    Well, G5s cannot boot OS9, only use it as "Classic" in 10.4.11

     

    Did you clone the G4 using the G4, then hook the clone up to the G5?

  • 5. Re: Clone 10.4.11 to empty HD
    Server rookie Level 1 Level 1 (40 points)

    I took the HD out of the G4 as the powersupply died. So I hooked the HD directly up to the Ultradock, then cloned directly from the HD to the G5.

  • 6. Re: Clone 10.4.11 to empty HD
    rccharles Level 5 Level 5 (5,370 points)

    What version of tiger is on the g4?  Could be the g4 version of tiger is missing some drivers.

     

    If you cannot get this to work...

     

    Install some os on the g5.

    Use migration assistant in utilitie folder to copy over g4 data & ids from old hd.

     

    Robert

  • 7. Re: Clone 10.4.11 to empty HD
    Server rookie Level 1 Level 1 (40 points)

    Thanks Robert. The OS is -like the thread says- 10.4.11. That system has run for years without any problems on the G4. So why should it miss some drivers? I try to understand. I can always install 10.4 from the original Tiger installer but I thought the cloning should work withouyt any problems. Thanks.

  • 8. Re: Clone 10.4.11 to empty HD
    BDAqua Level 10 Level 10 (116,480 points)

    Is the Ultradock hooked up via Firewire? And the MBP not connected to it?

     

    With the G4's drive in the Dock, boot G5 up holding alt key, does the G4 drive show as a boot choice?

  • 9. Re: Clone 10.4.11 to empty HD
    rccharles Level 5 Level 5 (5,370 points)

    alt key is also the option key.

     

    The g4 is a different processor from the g5.  It could be that there is some missing software for the g5 from the g4.  I do not know.  Just a guess.

     

    You could booting the g5 from the g4 disk. The would rule out a bad copy.

     

    Sometimes if volumes don't appear in Startup Manager (what you get when you hold down the Option key at startup), you need to reset the Mac's PRAM, NVRAM, and Open Firmware. Shut down the Mac, then power it up, and before the screen lights up, quickly hold down the Command, Option, P, and R keys, until the Mac has chimed twice more after the powerup chime. Then, before the screen lights up, hold down Command-Option-O-F until the Open Firmware screen appears. Then enter these lines, pressing Return after each one:

     

    reset-nvram

    set-defaults

    reset-all

     

    "The reset-all command should restart your Mac. If so, you have successfully reset the Open Firmware settings."

    http://support.apple.com/kb/TS1812?viewlocale=en_US

     

    How to eject a cd from the internal cd drive:

    eject cd

     

    List of devices:

    devalias

  • 10. Re: Clone 10.4.11 to empty HD
    Server rookie Level 1 Level 1 (40 points)

    Thanks Robert. Here are a few updates.

    The PRAM was already reset

    Now I've reset the OpenFirmware as well

    Booting the G5 with the disk connected trough the Ultradock is not working (the HD is not seen)

     

    So, does that leave me with installing Tiger through DVD and then use CCC for the rest?

  • 11. Re: Clone 10.4.11 to empty HD
    rccharles Level 5 Level 5 (5,370 points)

    You have the disk connected via firewire?  A must for the PPC with the exception of a few G5 systems.

     

    You could run disk utilty to see if there is a filesystem problem.

     

    Robert

  • 12. Re: Clone 10.4.11 to empty HD
    Server rookie Level 1 Level 1 (40 points)

    Yes Robert, connected through FW800. Here's a new update.

     

    I checked with DiskUtility using the OS10.4.3 installer. StartupDisk saw the the 10.4.11 system on the G5 and booted without success a few times.

    I did an Achive & Install using the OS10.4.3 installer with no success

    I did clean install of the OS10.4.3 installer wth no succes

    I did an erease and install with the OS10.4.3 installer and... Bingo!

     

    After installation I got a dialog asking me to clone over any data from an external machine. I was then able to clone over the missing data from the G4 drive. The only thing I have to do now is to update the system to 10.4.11 using a combo installer. After that I can upgrade to 10.5.8. But first some sleep. Thanks everyone!  

  • 13. Re: Clone 10.4.11 to empty HD
    BDAqua Level 10 Level 10 (116,480 points)

    Good work!