8 Replies Latest reply: Mar 3, 2013 1:30 PM by Ralph Johns (UK)
ajjarrett Level 1 Level 1 (0 points)

When I typed, "thank you very much," in Japanese in iChat the 'ri' in arigatou came up with a different character.

 

It should be り、but it was completely different. Strangely when I use Safari, or other programs it comes up correct. Even when I try to copy and paste the wrong character in this inquiry the character is changed so I cannot even show it to you.

 

  Does anyone else get the wrong Japanese character for 'ri' as their first option in iChat? This is quite annoying.


MacBook Pro, Mac OS X (10.6.8)
  • 1. Re: Anyone else getting the wrong Japanese character for 'ri' as the first option on iChat
    Tom Gewecke Level 9 Level 9 (71,730 points)

    Are you referring to the two common forms of "ri"?  Which one you see will depend on which font gets used.  See the Font Variation pane from Character Viewer below.  (To show things here, take a screen shot and use the Camera icon to upload it).

     

    Screen Shot 2013-02-09 at 10.21.20 AM.png

     

    The separated forms seem to come from Chinese and Korean fonts, although Osaka for Japanese also has it.  You might try to make sure that Japanese is higher on the list in system preferences/language & text/languages than Chinese or Korean.

  • 2. Re: Anyone else getting the wrong Japanese character for 'ri' as the first option on iChat
    ajjarrett Level 1 Level 1 (0 points)

    When I use iChat the 'ri' character I want is shown but it seems as if I cannot select it. I have tried both selecting from the first list #2 and from the transliteration list. Doens't work.

     

    I took a screen shot of it.

     

      I have tried many times to select the correct character for the simple phrase "thank you," but alas it doesn't seem to allow me to choose it.

     

    Screen shot 2013-03-03 at 10.51.15 AM.png

  • 3. Re: Anyone else getting the wrong Japanese character for 'ri' as the first option on iChat
    Tom Gewecke Level 9 Level 9 (71,730 points)

    You haven't understood.  They are both correct.  Which one you see depends on what font you have chosen for your display.  Which one the other end sees depends on what font they have chosen for their display.

     

    Try setting the font in iChat Preferences to Hiragino, and also make sure that in System Preferences/Language & Text/Language you have Japanese higher on the list than Chinese or Korean.

  • 4. Re: Anyone else getting the wrong Japanese character for 'ri' as the first option on iChat
    ajjarrett Level 1 Level 1 (0 points)

    Actually, I did understood what you wrote.

     

    I first selected Hirgana as the language I want to use.

     

      In the image I showed you it did give me the option for the character I 'wanted' to select, but for some reason it didn't allow me to do so. I would move the cursor on it, it would highlight but when I clicked on it it would do absolutely nothing. I even tried to select it on the transliteration list, but same problem it wouldn't allow me to select it.

     

      Here is another problem. What I have described doesn't happen in other programs I use. So it seems odd for iChat to be an exception. When I type "Thank you," which needs the character I am referring to, and not the other, it seems as if it cannot be done on iChat. I have done it on QQ, MSN, Gtalk, Pages, and it works perfectly fine.

     

      Thanks for trying to help me out here.

     

    I am attaching a photo to show you that the #2 character, the one I want, is selected but what shows in the text field isn't the same.

     

        Screen shot 2013-03-03 at 8.37.19 PM.png

  • 5. Re: Anyone else getting the wrong Japanese character for 'ri' as the first option on iChat
    Tom Gewecke Level 9 Level 9 (71,730 points)

    ajjarrett wrote:

     

    Actually, I did understood what you wrote.

     

    I first selected Hirgana as the language I want to use.

     

     

    But that is not what I wrote.  I asked you to set the FONT to HIRAGINO.   This is done in iChat > Preferences > Messages > Set Font.

     

    I also asked you to go to System Preferences > Language & Text > Language and make sure Japanese is higher on the list than Chinese or Korean.

     

    Please try doing those two things.

     

    Also it's important to understand that these are not two different characters.  They are two forms of the same character.  Even if you see a form you do not like, it does not mean that the person at the other end will see that.  They will see the form which their own font determines for them.

  • 6. Re: Anyone else getting the wrong Japanese character for 'ri' as the first option on iChat
    ajjarrett Level 1 Level 1 (0 points)

    Thank you.

     

    The first suggestion about going into preferences worked.

  • 7. Re: Anyone else getting the wrong Japanese character for 'ri' as the first option on iChat
    Tom Gewecke Level 9 Level 9 (71,730 points)

    ajjarrett wrote:

     

    The first suggestion about going into preferences worked.

     

    Good News!  However common it is to see the single-stroke "ri" in Japanese computer fonts, I understand it is still formally taught as two strokes, both for Hiragana and Katakana.

     

    http://en.wikipedia.org/wiki/Ri

  • 8. Re: Anyone else getting the wrong Japanese character for 'ri' as the first option on iChat
    Ralph Johns (UK) Level 9 Level 9 (67,495 points)

    Hi,


    Variations for other users.

     

    In this Pic I have selected "HOMESWEETHOMEOUTLINE" as the Outgoing (my) Font.  (it is all Upper Case)

    I have also selected an incoming Override font "JOYSTIX"

    The pic is from Messages in Mountain Lion but the top part of this pane is very similar across all versions.

     

    Screen Shot 2013-03-03 at 21.17.38.png

     

    iChat or Messages may well be sending the Font  "HOMESWEETHOMEOUTLINE" to my Buddies.

    They will only see that Font if:-

    1) They have that Font.

    2) They are not using Incoming Override.

     

    The same applies to the Colours of the Fonts which also can be changed and the "Balloon" colour.

    FontChanges.png

     

    Broadly speaking use Dark on Light or Light on Dark.

     

     

    3Sigcopy2.png
    9:30 PM      Sunday; March 3, 2013


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously