Skip navigation

Aperture 3 stalls while importing photo folders

2762 Views 11 Replies Latest reply: Jul 1, 2013 9:24 AM by sparkfury RSS
robphoton Level 1 Level 1 (20 points)
Currently Being Moderated
Oct 23, 2012 4:53 PM

It appears that one of the latest updates for Aperture 3 now creates a situation where it just stops importing, even though it says it is still importing.  The progress wheels stop moving and the hard drive stops blinking and it just sits there.  This problem did not exist before one of the more recent updates.  Yes, it does now import faster, but it is now unreliable.  I now only import about 6 folders at a time because about every six or eight batches of folders I have to activate Quit Aperture, where it does not quit, and then I have to use option command escape to force quit.  Then I reload and have to inspect to see if some of the folders need to be reinstalled.  A pain in the butt.  I would rather have a slower, more reliable folder import.

27" imac i5 quad, mbp 15", Mac OS X (10.6.5), many TB of external drives, iPhone 4, ATV
  • léonie Level 8 Level 8 (46,475 points)
    Currently Being Moderated
    Oct 23, 2012 11:18 PM (in response to robphoton)

    I suspect your Aperture Library needs repairing. If you force quit Aperture, the Aperture Library may be left in an inconsistent state, because Aperture cannot complete the current transactions.

     

    Before you try to import again, run the Aperture Library First Aid tools, to repair (or rebuild if necessary) your Aperture library.

    Aperture 3 User Manual: Repairing and Rebuilding Your Aperture Library

     

    If Aperture frequently hangs, try to avaoid force quit - it is risky with database applications. Sometimes you can quit an application from the Terminal, if it is unresponsive, see my user tip here:

    If Aperture is unresponsive, how to avoid force quitting?

     

    Besides an inconsistent Aperture Library that needs repairing, you may have imported an image or video that cannnot be processed, because it is defective or has an incompatible format. Than Aperture will try over and over again to process that one image or video and hang. Then you need to isolate the one imort that is causing this.

     

    Regards

    Léonie

  • Kirby Krieger Level 6 Level 6 (11,570 points)
    Currently Being Moderated
    Nov 5, 2012 2:21 PM (in response to robphoton)

    I suggest ruling out peripherals such as cards and card-readers, cables, etc.

     

    I only recently upgraded to 3.4.2, but I have imported a few hundred finder folders as Aperture Projects and have not had any slow-downs or hangs.

  • léonie Level 8 Level 8 (46,475 points)
    Currently Being Moderated
    Nov 5, 2012 2:41 PM (in response to robphoton)

    Also I should point out that the problem appears not only with my imac but also my macbook pro, so it is not the computer's fault.

    Besides the peripherals Kirby mentioned - are there any other common factors on both your machines - third party software, like non-standard preference panes? For example the "Cameras" preference pane from Flexibits is no longer compatible with Aperture 3.4.2. and has caused crashes. You may wish to check your preference Panes, Aperture plug-ins, start-up items for add-ons that you use on both machines and that may need updating to 64-bit versions.


  • jrf000 Calculating status...
    Currently Being Moderated
    Nov 25, 2012 10:19 PM (in response to robphoton)

    I'm having the same problem. Aperture is working fine until I try and import raw files from my Canon 7D. It reads all the images and they appear in the import screen, but when I click on "Import Checked" it hangs and freezes the whole machine. Help!

  • Aye Es Oh Level 2 Level 2 (330 points)
    Currently Being Moderated
    Nov 26, 2012 9:27 AM (in response to jrf000)

    jrf, did you rule out everything that was mentioned above, i.e. did you use different card readers/cables/cards, and did you repair and, failing that, rebuild your library?

  • jrf000 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 28, 2012 10:39 PM (in response to Aye Es Oh)

    Thanks for the reply.  I tried different USB cables and even bought a CF card reader.  Nothing worked.  When I plugged in another camera that had JPEGs and not RAW files it imported fine.  And sadly there is no crash report since Aperture brings down my whoel computer. Also, the CF card seems fine since the computer is abe to read the card and open images.

  • Aye Es Oh Level 2 Level 2 (330 points)
    Currently Being Moderated
    Nov 29, 2012 8:19 AM (in response to jrf000)

    And just to be sure, did you attempt to repair or rebuild the database for your library by holding down Command and Option while starting up Aperture? Does importing into a different library work?

  • brandonis Calculating status...
    Currently Being Moderated
    Feb 9, 2013 4:02 PM (in response to robphoton)

    I realize that this is an older issue, but it recently started happening to me.

     

    Found out that it was because I had an android phone charging from one of the USB ports. In my case, anytime I have the phone plugged in, Aperture import was stall.

  • Haggardly Level 1 Level 1 (5 points)
    Currently Being Moderated
    May 1, 2013 10:10 AM (in response to robphoton)

    Aperture crashes everytime I import photos from the compact flash reader.  Sometime requiring it to spend half an hour rebuilding the library before I can print out the photos I just imported.  Very anoying.  I could get a new card reader but I don't want to waste the money if it's just a software problem.

  • sparkfury Level 1 Level 1 (10 points)
    Currently Being Moderated
    Jul 1, 2013 9:24 AM (in response to robphoton)

    I found a sequence that has worked for me a couple of times, first with a managed library and also with a referenced library. Once you see in the Activity window that nothing is progressing, select the root Folder Import and hit Pause Task. This should pause everything. Now, go and try to Quit Aperture. This will send you a warning that you are Importing, etc. and give you either Quit or Continue. Select Continue.

     

    Go back to the Activity window and select the root Folder Import and hit Run Task. It should be working again.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.