Skip navigation

How do i get my Nikon photos from viewNX 2 into the iPhoto library?

922 Views 5 Replies Latest reply: Feb 10, 2013 2:45 PM by Old Toad RSS
old yukon Level 1 Level 1 (0 points)
Currently Being Moderated
Feb 9, 2013 6:45 PM

1. How do I get my Nikon photos from ViewNX 2 into the iPhoto Library?

2.I tried by copying them and moving to the iphoto folder. Now the Iphoto applicationwon't open because it is locked. the help item says to open it with command option keys down to get the iphoto library First aid window. it does not come up.

iPhoto '11, OS X Mountain Lion (10.8)
  • Old Toad Level 10 Level 10 (112,985 points)

    How did you add the photos to the iPhoto Library folder?  The way to import photos is to drag them onto the iPhoto icon in the Dock or into the open iPhoto window.  

    it does not come up.

    What does not come up?  What happens when you try to launch iPhoto with those two keys held down?

     

    Try the following again being sure to hold those keys down before launcing iPhoto and until the window opens:

     

    Apply the two fixes below in order as needed: 

     

    Fix #1

     

    Launch iPhoto with the Command+Option keys held down and rebuild the library.

     

    iP93rebuild.PNG

     

    Since only one option can be run at a time start with Option #3, followed by #4 and then #1 as needed.

     

    Fix #2

     

    Using iPhoto Library Manager  to Rebuild Your iPhoto Library

     

    1 - download iPhoto Library Manager and launch.

     

    2 - click on the Add Library button, navigate to your Home/Pictures folder and select your iPhoto Library folder.

     

    3 - Now that the library is listed in the left hand pane of iPLM, click on your library and go to the File ➙ Rebuild Library menu option.

     

    4 - In the next  window name the new library and select the location you want it to be placed.

     

    5 - Click on the Create button.

     

    Note: This creates a new library based on the LIbraryData.xml file in the library and will recover Events, Albums, keywords, titles and comments.  However, books, calendars, cards and slideshows will be lost. The original library will be left untouched for further attempts at fixing the problem or in case the rebuilt library is not satisfactory.

     

     

    OT

  • Old Toad Level 10 Level 10 (112,985 points)

    Where is the library located?

  • Old Toad Level 10 Level 10 (112,985 points)

    Try this: 

     

    1 - download and run  BatChmod.  Drag the library into the window set the settings as shown in this screenshot:

    BatChmod.PNG

    2 - click Apply

    3 - try to launch iPhoto again.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.