5 Replies Latest reply: Feb 10, 2013 9:04 PM by Badunit
ellenr Level 1 Level 1 (0 points)

I accidentally deleted most of my keywords. Is there any way to find them and get them back? The undo command doesn't seem to have any effect. Is there perhaps a way to quit Aperture without saving the changes, or is this not possible?

  • 1. Re: most of keywords got deleted.
    Tony Gay Level 4 Level 4 (1,625 points)

    How long is it since you updated your vault or other backup?

    If recently use your vault to get the keywords back.

     

    Unsure how to do this, ask before doing anything as you may loose any work you have added to your library since your last backup.

     

    Tony

  • 2. Re: most of keywords got deleted.
    ellenr Level 1 Level 1 (0 points)

    Thanks. I don't use the vault, but I backed it up on an external hard drive not very long ago, so I won't loose too much if I just replace with the backed up version.

    Ellen

  • 3. Re: most of keywords got deleted.
    Tony Gay Level 4 Level 4 (1,625 points)

    What you can do is export the projects added since you backup, reinstate the backup and then import the those projects into the reinstated backup.

     

    Tony

  • 4. Re: most of keywords got deleted.
    Badunit Level 6 Level 6 (10,815 points)

    Mine got deleted too. I opened the Keyword HUD and a bunch of keywords (folders and subfolders) were highlighted. First time I've seen that happen. I went to drag a keyword to an image and it looked like it was going to drag all the highlighted ones. So I put the mouse back over the keyword HUD and let go. To my surprise, several folders full of keywords (and their folders) got deleted and many of the other keywords were moved out of their folders. I guess ESC would have been the better choice (hindsight is 20:20) but, still, what the heck was that all about?

     

    My images still have the keywords and the keywords show up in the Search box but if I search on any of those keywords, no images are found. I'm not adverse to keying them all back in again but that doesn't seem to work. I tried re-typing one into the HUD but, again, no images have that keyword (even though many of them actually do).

     

    I have a relatively recent vault. Rather than restoring everything, how can I restore the keywords only? Can I simply replace the Keywords.plist file with the one from the vault? I'd try myself instead of asking but I don't want to make things worse.

  • 5. Re: most of keywords got deleted.
    Badunit Level 6 Level 6 (10,815 points)

    Restoring keywords didn't work.Restored entire library (well,almost ... it is still processing previews). Looks like that worked.  Good thing I back up to a vault every time I add images. I'll check it out tomorrow when it is complete.