0 Replies Latest reply: Feb 11, 2013 7:52 AM by fvd
fvd Level 1 Level 1 (5 points)

I have os x 10.6.8 Snow Leopard and Safari 5.1.7  I have heard that some people have had problems in the past. If there is any kind of significant risk, I just won't do it.


imac, Mac OS X (10.5.2)