2 Replies Latest reply: Feb 11, 2013 8:26 AM by lllaass
anuj812 Level 1 Level 1 (0 points)

I am not able to install any application. I am getting pop saying it requires iOS 4.3. But when i tr to upgrade my touch to 4.3 from 4.2.1, it says its running on latest iOS. Please help. Is my touch is waste now as apple don't support. Please help


iPod touch (2nd generation), iOS 4.2