Skip navigation

i am not able to install application. i am getting that it requires IOS 4.3

109 Views 2 Replies Latest reply: Feb 11, 2013 8:26 AM by lllaass RSS
anuj812 Calculating status...
Currently Being Moderated
Feb 11, 2013 6:07 AM

I am not able to install any application. I am getting pop saying it requires iOS 4.3. But when i tr to upgrade my touch to 4.3 from 4.2.1, it says its running on latest iOS. Please help. Is my touch is waste now as apple don't support. Please help

iPod touch (2nd generation), iOS 4.2
  • Peizoandme Level 3 Level 3 (535 points)

    You have an old iOS device that is only capable running 4.2. The application needs later operating system you will have to buy a newer device that supports the later OS.

  • lllaass Level 10 Level 10 (135,205 points)

    I suspect you have a 2G iPod. Those can only go to iOS 4.2.1.

    Identifying iPod models

    iPod touch (3rd generation)

    iPod touch (3rd generation) features a 3.5-inch (diagonal) widescreen multi-touch display and 32 GB or 64 GB flash drive. You can browse the web with Safari and watch YouTube videos with Wi-Fi. You can also search, preview, and buy songs from the iTunes Wi-Fi Music Store on iPod touch.

    The iPod touch (3rd generation) can be distinguished from iPod touch (2nd generation) by looking at the back of the device. In the text below the engraving, look for the model number. iPod touch (2nd generation) is model A1288, and iPod touch (3rd generation) is model A1318.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.