1 2 3 Previous Next 33 Replies Latest reply: Jul 12, 2013 6:33 PM by mikefromthe canyon Go to original post
  • 15. Re: Safari 6.0.1 page loading slow or not at all
    sam b. Level 1 Level 1 (0 points)

    Oooops. Tried once more with commands in Terminal and it worked (I think that I did not follow the order of Quitting from Safari after the initial change) ...... the disabling and the re-enabling. Unfortunately problem IS still with me in both modes...........

    sam

  • 16. Re: Safari 6.0.1 page loading slow or not at all
    sam b. Level 1 Level 1 (0 points)

    Would it help if I tried the process again and posted the results as text?

    sam

  • 17. Re: Safari 6.0.1 page loading slow or not at all
    Linc Davis Level 10 Level 10 (117,765 points)

    If you say you've disabled prefetching, I have to assume it's true.

     

    I've thought about your problem quite a bit, and my conclusion is that either some of what you've told me is inaccurate, or you're somehow triggering a bug in OS X that I've never heard of. I have not the slightest idea how that could happen. I'm running Safari 6.0.1 and OS X 10.8.2 on a Mac Pro, and I don't have your problem. I've seen no other reports on this site consistent with yours.

     

    Since I don't know what's going on, I'm not going to make any suggestions that I would only expect to waste more of your time. As a last resort, take the machine to an Apple Store for testing. That, too, will be a waste of time unless you can reproduce the problem there.

  • 18. Re: Safari 6.0.1 page loading slow or not at all
    sam b. Level 1 Level 1 (0 points)

    Linc,

     

    Ok. Thanks for your time anyway, I appreciate it. FWIW my problem with the Prefetching was a rouge space at the head of the copy/paste operation I performed in Terminal. Fixed that.

     

    The problem that I have with Safari is constant so I expect that there would no no problem reproducing it elsewhere. I do have one question though and I am sorry to take up so much of your time, but I noticed in the Recovery mode that there is an option to re-intall ML. Do you think this is worth a try?

     

    Thanks and promise not to take up more time,

    cheers,

    Sam

  • 19. Re: Safari 6.0.1 page loading slow or not at all
    Linc Davis Level 10 Level 10 (117,765 points)

    Do you think this is worth a try?

     

    I have no reason to think it will help, but it does no harm, as long as you have backups.

  • 20. Re: Safari 6.0.1 page loading slow or not at all
    sam b. Level 1 Level 1 (0 points)

    Linc,

     

    I know that I promised NOT to bother you but I thought that you would like to know, as you seem to be a bit of a guru around this community. While in Recovery mode I noticed the Disk Utility and ran it to repair permissions. Previously I ran it while the OSX was up and running normally (also via Appljack in Single User Mode). On both those occasions there were NO permission issues until now. In Recovery Mode Disk Utility found com.apple.alf.plist to have incorrect permissions. Repaired and now no issues with hangs/slowdowns etc.

     

    Just FYI.

     

    Thanks for you continued help and cheers for now!

    Sam

  • 21. Re: Safari 6.0.1 page loading slow or not at all
    Linc Davis Level 10 Level 10 (117,765 points)

    I'm glad to hear things have improved, but wrong permissions on that file, or indeed on any file, could not possibly have caused Safari to run slowly in recovery mode.

  • 22. Re: Safari 6.0.1 page loading slow or not at all
    MadMacs0 Level 4 Level 4 (3,725 points)

    sam b. wrote:

     

    Previously I ran it while the OSX was up and running normally (also via Appljack in Single User Mode).

    Just so you know, Applejack has not been able to repair permissions since Snow Leopard. I doubt that it's a good idea to use it in Mountain Lion, at all.

  • 23. Re: Safari 6.0.1 page loading slow or not at all
    sam b. Level 1 Level 1 (0 points)

    thanks for that MadMacs0 I will avoid it in fuure.

    cheers,

    sam

  • 24. Re: Safari 6.0.1 page loading slow or not at all
    rlopez007me Level 1 Level 1 (0 points)

    I found a solution that works!!! Using commad-R entered into recovery and reinstalled Mountain Lion fresh.

    Problem Solved, I will not update tu later versions until the issue is resolved.

    Safari Roars!!!!! but the older version.

     

    Ricardo L.

  • 25. Re: Safari 6.0.1 page loading slow or not at all
    estherissima Level 1 Level 1 (0 points)

    I have been having the same problem with Safari 5.1.7 and Snow Leopard. It's loading pages very slowly or not at all. I have tried a number of things but not as sysematically as Sam B and others. If I find a solution, will post here. Otherwise, I've gotten to the point that I must switch to Chrome or FF as my default browser.

  • 26. Re: Safari 6.0.1 page loading slow or not at all
    giovannifg Level 1 Level 1 (0 points)

    Hi there!

     

    More or less same problem here. I'm running Mac OS X 10.8.2. on a MacBook Air (Mid 2012). Safari was just running fine, until one day - I don't even precisely remember when, since in the beginning I probably thought it had to do with the ADSL line - it started to load *some* pages really slow.

     

    This is what happens more in detail:

    • I type an address or click on a bookmark or somehow prompt Safari to load a a page
    • It starts loading, meaning that the title gets loaded and the bar starts moving
    • Then it stops, and sometimes will not move until i update the loading
    • If I force it to load again, then the page will display quickly

     

    The curious thing is that it doesn this only with some websites, and only sometimes.

     

    So far, I've tried to disable prefetch by issuing the command:

         defaults write com.apple.safari WebKitDNSPrefetchingEnabled -boolean false

    in the terminal. It seems to work immediately after, but then its effect kind of fades: I wonder if maybe DNS prefetch somehow activates again? Is there a way to check whether it is activate or not?

     

    I've also tried using the Google DNS service (8.8.8.4 and 8.8.8.8), but to no avail.

     

    I'm still stuck with the problem. Any suggestion is much appreciated, of course!

     

    Thank!

  • 27. Re: Safari 6.0.1 page loading slow or not at all
    giovannifg Level 1 Level 1 (0 points)

    I've tried running the "repair permission" option from disk utility. Apparently, there were some 10 files with wrong permission settings. By the way, do I need to worry about that?

     

    Anyway, after I ran it, now the situation seems far better, I would say Safari is now working ok.

     

    I'll wait and see if the problem comes back.

     

    Anyone has a reasonable explanation about why permission settings should impact Safari performance?

  • 28. Re: Safari 6.0.1 page loading slow or not at all
    MadMacs0 Level 4 Level 4 (3,725 points)

    giovannifg wrote:

     

    I've tried running the "repair permission" option from disk utility. Apparently, there were some 10 files with wrong permission settings. By the way, do I need to worry about that?

    Mac OS X: Disk Utility's Repair Disk Permissions messages that you can safely ignore

    Anyone has a reasonable explanation about why permission settings should impact Safari performance?

    Not without seeing what was repaired.

  • 29. Re: Safari 6.0.1 page loading slow or not at all
    giovannifg Level 1 Level 1 (0 points)

    Thanks for the link!

     

    I'm really a newbie in the Mac world, so I cannot precisely recall the exact files, nor I kept a log. I'm sorry!

     

    Anyway, the problem is still there, and I really cannot figured it out, since it apparently affects only some websites, random. Sometimes Safari will get stuck while loading page, and I have to tell it to reload it again; most times it will work ok.

     

    It al started with no apparent reason... I don't even really know where to start looking!