Skip navigation

Kernel panics in 10.5.8 caused by screensaver

1555 Views 13 Replies Latest reply: Feb 11, 2013 10:18 AM by Murphypf82 RSS
PIT56 Calculating status...
Currently Being Moderated
May 10, 2011 12:59 PM

Ok. I've been suffering form kernel panics ever since I upgraded from 10.4.11. Sometimes three a day. I have, as you might expect, tried everything including a reinstall of 10.5.1 followed by the 10.5.8 combo updater. But still the problem persisted. So I began removing or disabling items one by one until the kernel panics went away. Then I reintroduced them until a KP struck. And guess what, it turned out to be the screensaver. No doubt about it. I've tested and retested it. With any Apple screensaver on, a KP will eventually strike; while I'm browsing, working or even while I'm away from the Mac. There's no pattern that I can discern, but I'm now absolutely sure that I've traced down the culprit. Could this be the hidden cause of so many reported KPs? If so, it's a hidden menace. Fortunately, you can switch off the saver and simply set your monitor to sleep after a period of inactivity. It's not ideal, but it's better than suffering multiple crashes every day.

G5 Quad, Mac OS X (10.5.8)
  • Klaus1 Level 8 Level 8 (43,350 points)
    Currently Being Moderated
    May 10, 2011 2:50 PM (in response to PIT56)

    Kernel panics are more usually caused by hardware issues.


    What screensaver left over from Tiger are you using?


    What is a Kernel Panic?






    More details here:



    Useful article on how to avoid and eliminate kernel panics here:


    20" 2.1GHz iSight iMac G5,, Mac OS X (10.5.8), iLife 9 but iMovie 6, QTPro 7.6.9, Safari 5.0.5
  • roam Level 6 Level 6 (13,545 points)
    Currently Being Moderated
    May 11, 2011 3:35 AM (in response to PIT56)

    Does the screensaver get a mention in the crash log?


    Is it a standard Mac screensaver or a downloaded one?

  • roam Level 6 Level 6 (13,545 points)
    Currently Being Moderated
    May 11, 2011 4:36 AM (in response to PIT56)

    Definitely an odd one then. You could try running your Apple hardware test CD if you have one, just to check out the video card.

  • sruben Calculating status...
    Currently Being Moderated
    Sep 23, 2011 5:50 AM (in response to PIT56)

    I just saw your post while trying to track down kernel panic on my Power Mac G4 OS 10.5.8 (recently updated). The computer would run fine until I walked away and it went to sleep. I had screen saver set to never. I would get the KP when I woke the computer. I set the screensaver to come on now before sleep and no more KP's  I also went through the various hardware tests and found nothing. Although when I did get a KP the log seemed to indicate that it was Logitech control center that may be the culprit. I also set the computer to no sleep, no saver and there are no panics. I would have to agree that something about the sleep/saver interface is causing the problem and it only affects 10.5.8 on my machine. Other OS X's don't seem to have the problem. Any luck tracking this down? plist, etc

  • Murphypf82 Calculating status...
    Currently Being Moderated
    Feb 4, 2013 2:08 PM (in response to sruben)

    I have the same problem on my PPC running 10.5.8.


    Have had two KPs in the last week, both times when I left the computer running for a while without using it, about 30 minutes each time.


    I have screensaver on but sleep was set to never.


    Any advice gratefully received.




    Mon Feb  4 21:53:11 2013

    Unresolved kernel trap(cpu 1): 0x400 - Inst access DAR=0x000000001C823000 PC=0x000000001C823000
    Latest crash info for cpu 1:
      Exception state (sv=0x76c95000)
    PC=0x1C823000; MSR=0x40009030; DAR=0x1C823000; DSISR=0x40000000; LR=0x1C823000; R1=0x68E6BE80; XCP=0x00000010 (0x400 - Inst access)
      backtrace terminated - unaligned frame address: 0x68E6BDFC

    Proceeding back via exception chain:
      Exception state (sv=0x76c95000)
    previously dumped as "Latest" state. skipping...
    Exception state (sv=0x68fcac80)
    PC=0x00098444; MSR=0x0000F030; DAR=0x1C823000; DSISR=0x40000000; LR=0x00091DF0; R1=0xF007FAA0; XCP=0x0000000C (0x300 - Data access)

    BSD process name corresponding to current thread: ReportCrash

    Mac OS version:

    Kernel version:
    Darwin Kernel Version 9.8.0: Wed Jul 15 16:57:01 PDT 2009; root:xnu-1228.15.4~1/RELEASE_PPC
    System model name: PowerMac11,2

    System uptime in nanoseconds: 37752540910764
    unloaded kexts:     2.5.8f1 - last unloaded 3554503227
    loaded kexts:
    com.logmein.driver.LogMeInSoundDriver     1.0.0     32.7 - last loaded 1171820437     2.1.10f2     194.28     2.4.0     2.1.10f2     2.0.2     2.5.8f1     2.5.8f1     5.4.8     5.4.8     2.5.8f1     2.5.8f1     1.0.6     3.4.0d0     2.5.8f1     1.3.2     1.9d0     1.9d0     1.9d0     1.7.7     1.7.2f1     1.9d0     1.9d0     1.9d0     1.0.1f1     1.5.2d0     1.1.1d2     1.1.0     3.4.6     3.2.0     2.1.10f2     2.1.1     2.1.1     2.7.91     2.0.6     3.4.9     1.5.3     3.5.2     1.0.4f2     1.3.0d0     1.3.0d0     2.2.3b1     1.5.3     4.0.0d2     1.1.1d2     3.9.7     1.2.1f4     1.0.5b1     3.4.6     3.4.6     1.7.2f1     1.2.1d1     3.4.0     1.1.1     1.0.5     107.12     1.8.77

  • zombi3g Level 1 Level 1 (40 points)
    Currently Being Moderated
    Feb 4, 2013 2:22 PM (in response to Murphypf82)

    You might try disabling this non-Apple kext you have in there:



  • Murphypf82 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 11, 2013 10:01 AM (in response to zombi3g)

    Thanks for your advice, I tried that, or at least I unstalled logmein, but I got another one yesterday (KP), a few infact.


    In the end the machine refused to boot again, so I replaced the HD, still nothing.


    So I removed the RAM, some of which was recently added. One pair made it crash on startup, while the others worked fine.


    Strange thing is though, the orginal HD will not now work, tried hooking it up to an external reader, and while it was spinning it wouldn't show up on the desktop.


    To be honest, I'm hoping it was one or the either but find it a bit strange that both were a problem.


    I got the RAM from 'Mr Memory', firstly ordered 8gb (2x2) but only 4gb would show.

    Sent them back, got the new set to work but started getting the panics shortly after.


    Probably gonna just stick with the RAM I have in it now and look for my money back for the others.


    Also ordered a new HD and will do a fresh install when it arrives.


    Again I'd be grateful for any advice.

  • Klaus1 Level 8 Level 8 (43,350 points)
    Currently Being Moderated
    Feb 11, 2013 10:08 AM (in response to Murphypf82)

    Your RAM is prime suspect. Cheapest RAM often is.


    Stick with RAM from OWC and Crucial, both of which have a lifetime warranty.

  • Murphypf82 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 11, 2013 10:18 AM (in response to Klaus1)

    Thanks, appreciate the reply.


    The RAM I bought does have a lifetime warranty but I cannot vouch for its quality.


    Reason I went for this is simply because it's what was in the machine, just wanted to add to it.


    What do you think about the HD failing too then? Just chance?


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.