1 2 Previous Next 24 Replies Latest reply: Mar 8, 2013 6:36 PM by Domovika
Domovika Level 1 Level 1 (0 points)

I have an iPhone 4S, , iOS 6.1.1, and an iMac running 10.6.8.  Whenever I sync my phone to my computer whatever I have added on my iMac's calendar will go to my phone's calendar, but anything new that I add to my iPhone calendar doesn't sync to my iMac.  Does anyone else have this problem? I never had this problem with my old iPhone. 

 

I have checked all my settings and everything seems to be as it should be. A few times it has added apointmets from my phone to my calendar, but I would say 90% of the time it doesn't.

Any help will be greatly appreciated.

 

  • 1. Re: calendar sync problem
    Eric Ross Level 6 Level 6 (11,660 points)

    Make sure have your default calendar on your iPhone set to your icloud account.  Go into your settings>mail, contact,calendar scroll down to calendar then select your default calendar.

  • 2. Re: calendar sync problem
    randers4 Level 9 Level 9 (57,340 points)

    Check Settings>Mail,Contacts,Calendars>Default Calendar to be sure you have selected a calendar listed under you iCloud account as your default.  If not, make this change, then add a new event and see if it syncs properly.

     

    If your setting here is correct, add any missing events on your phone to your iCloud calendar, either on icoud.com from your computer, or in iCal.  Then go to Settings>iCloud, turn Calendars to Off, choose Delete from My iPhone when prompted, then after your calendar has cleared turn it back to On to sync your iCloud calendars back to your phone.  Then enter a new event and see if it syncs properly now.

  • 3. Re: calendar sync problem
    Domovika Level 1 Level 1 (0 points)

    Thank you Eric Ross.  When I go to Settings>mail, contacts,Calendar, then to calendar, there's nothing there but the list of different calendars I've made, like "home", "work", etc. Nothing about the cloud. But what if I don't want to use the cloud to sync?

  • 4. Re: calendar sync problem
    Domovika Level 1 Level 1 (0 points)

    Thank you Randers4, I just turned on iCloud for the calendar, and tried to sync to my computer, and all it did was double my appointments on my phone, still not going to the computer.

    I would have to go through every day of the  year to copy all my appointments from my phone manually, since I add appointments every day, but (this is my bad) I don't sync my phone more than once every couple weeks.

  • 5. Re: calendar sync problem
    randers4 Level 9 Level 9 (57,340 points)

    I think we were both assuming that you were already syncing your calendar with iCloud, and you were saying that it wasn't working.  If you don't want to sync your calendar with iCloud, you can simply go to Settings>iCloud on your phone and turn Contacts to Off, and when prompted, choose Delete from My iPhone.  This should delete the duplicate calendar entries from your phone. 

     

    If it deletes all calendar enteries instead, you can replace the calendar on your phone with the calendar in iCal by doing the following:

     

    1. Without connecting your phone, open iTunes on your computer and go to iTunes>Preferences>Devices and check "Prevent...from syncing automatically"
    2. Connect your phone to your computer, click on the name of your phone in iTunes, go to the Info tab of your iTunes sync settings.  Confirm that you have checked Sync Calendars, then further down under Advanced-Replace information on this iPhone, check Calendars.
    3. Click Apply at the bottom to sync your phone.  This will sync your iCal calendar to your phone.
  • 6. Re: calendar sync problem
    Domovika Level 1 Level 1 (0 points)

    I'm sorry, I guess I should have mentioned I wasn't using iCloud, and the reason I haven't been using it, if I remember right, is that it keeps doubling up entries, calendar and phone book.  I turned it off, and it did delete the duplicates.  My problem is that when I book a new event on my iPhone calendar, when I sync it doesn't copy the events to the computer, but when I book them on the computer they do sync to the phone.  I'm a personal care assistant, so I'm often taking people to the doctor, and of course I'm booking new appointments on my phone, I just can't get most things that I book on my phone to go to the computer.  That's the weird thing, that sometimes it will sync them, but not most of the time.

     

    Again, thanks for your help.

  • 7. Re: calendar sync problem
    randers4 Level 9 Level 9 (57,340 points)

    Sometimes resetting the SyncServices folder will restore bi-directional calendar syncing again in iTunes.  This guide explains how to do this: http://support.apple.com/kb/TS1627.

  • 8. Re: calendar sync problem
    Domovika Level 1 Level 1 (0 points)

    Ok, let me try that and I'll let you know what happens. Thanks!

  • 9. Re: calendar sync problem
    Domovika Level 1 Level 1 (0 points)

    Resetting SyncServices did not work.

  • 10. Re: calendar sync problem
    Domovika Level 1 Level 1 (0 points)

    And I tried this as well, still won't sync my phone calendar to my computer.

     

    http://support.apple.com/kb/TS2481

  • 11. Re: calendar sync problem
    Eric Ross Level 6 Level 6 (11,660 points)

    What cloud service are you using?

  • 12. Re: calendar sync problem
    Domovika Level 1 Level 1 (0 points)

    I'm not using the cloud because when I do it duplicates my calendar events and address book. I plug my iPhone to my iMac to sync.

    It's 3 AM here, and I just got done cleaning up my calendars, it still won't sync from the phone to the Mac, but whatever I do on the Mac syncs to the phone.  I'm going to try and reset the sync services and do the trouble shooting again, see what happens.

  • 13. Re: calendar sync problem
    Eric Ross Level 6 Level 6 (11,660 points)

    Take a look at this link, http://support.apple.com/kb/PH12317

  • 14. Re: calendar sync problem
    Domovika Level 1 Level 1 (0 points)

    That was a link on how to sync for Windows, I'm using an iMac.

    Thanks for your help, I'm done for tonight I think.  I just did the troubleshooting again and it's still not working right.  I'll keep trying in the morning.

1 2 Previous Next