2 Replies Latest reply: Feb 13, 2013 5:57 AM by mic_mn
mic_mn Level 1 Level 1 (0 points)

Dear all,

 

I have changed Decimal/Thousand Separator in General Settings, under Regional settings.

Decimal Separator is "dot" and thousand separator is "comma".

 

Apple Calculator, Numbers, MS Excel ... they all reflect these settings, but Terminal does not.

 

e.g. typing " du -sh * " I get a list of files and directories in which first column is reported with comma ad decimal separator.

I admit I have a "weird" configuration: US keyboard and Italian Language for Mountain Lion...

 

 

Any hints would be very welcome.

 

Thanks a lot

 

cheers

Mic


MacBook Air, OS X Mountain Lion (10.8.2)
  • 1. Re: how to change decimal separator (terminal does not reflect General Settings)
    BobHarris Level 6 Level 6 (13,110 points)

    The Unix command line world does not care about those "Upstart" GUI interfaces :-)

     

    locale is what controls the output and behavior of "Some" commands and utilities (but not all).  See "man locale" to start.

     

    Here is the output from my locale command on my U.S. Macbook Pro

     

    locale
    
    LANG="en_US.us-ascii"
    LC_COLLATE="en_US.us-ascii"
    LC_CTYPE="en_US.us-ascii"
    LC_MESSAGES="en_US.us-ascii"
    LC_MONETARY="en_US.us-ascii"
    LC_NUMERIC="en_US.us-ascii"
    LC_TIME="en_US.us-ascii"
    LC_ALL=
    

     

    Also see:

     

    locale -a
    

     

    As I said, not all commands and utilities bother looking at the locale environment variables, so you may not get consistent results when you change your locale.

  • 2. Re: how to change decimal separator (terminal does not reflect General Settings)
    mic_mn Level 1 Level 1 (0 points)

    thank you very much indeed Bob!

     

    I added the statement

     

       setenv LC_NUMERIC en_EN.UTF-8

     

    to my .cshrc and now the decimal separator is the period.

     

    cheers