Skip navigation

How to set up IMessage on my mac:

62125 Views 10 Replies Latest reply: Jun 27, 2013 5:42 AM by Olyts RSS
pgunter25 Level 1 Level 1 (0 points)
Currently Being Moderated
Feb 10, 2013 9:41 PM

My phone number for my Iphone 4s is associated with my Apple ID however, it does not show up in my IMessage preferences on my mac and thus all messages I send from iMessage are sent from my Apply ID email.

MacBook, OS X Mountain Lion (10.8)
  • Ralph Johns (UK) Level 9 Level 9 (66,815 points)
    Currently Being Moderated
    Feb 11, 2013 12:31 PM (in response to pgunter25)

    hi,

     

    Place the iPhone into Airplane mode for a few minutes.

     

    When it is back in normal more Restart Messages on the Mac.

    At this point the process should generate an alert type message from the iMessage Server on the Mac to says the iPhone is using the Apple ID and iPhone number.

     

    Accepting the same places the iPhone Number in the Messages Menu > Preference > Account > iMessage pane > Received "alias" List.

    It also places it in the Drop down at the Bottom as a potential "Send From" ID.

     

    3Sigcopy2.png
    8:31 PM      Monday; February 11, 2013


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • Ralph Johns (UK) Level 9 Level 9 (66,815 points)
    Currently Being Moderated
    Feb 12, 2013 1:24 PM (in response to pgunter25)

    HI,

     

    I once had an iPhone that was not showing it's own Number as ticked (Only greyed out).

    Being greyed out it could not be change.

     

    Although long winded I did the following:-

    Took the Apple ID out of the Send and Receive part of Settings > Messages > Send and Receive on the iPhone.

    Put the iPhone in Airplane Mode for few minutes.

    On activating the iPhone I checked to see if the iPhone Number was re-ticked.

    I re-added the Apple ID.

    I put it back in to Airplane Mode for another few minutes (I wanted to be sure of a definite "Start Point")

    When I had reactivated it I check both iPhone Number and Apple ID were ticked.

    Then I restarted Messages on the Mac.

     

    On the Messages restart I got the message from the iMessages server about what the iPhone was using and Accepting this placed the iPhone Number in Messages

     

     

    3Sigcopy2.png
    9:24 PM      Tuesday; February 12, 2013


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • Ralph Johns (UK) Level 9 Level 9 (66,815 points)
    Currently Being Moderated
    Feb 12, 2013 2:06 PM (in response to pgunter25)

    Hi,

     

    I have just noticed that your original Posts lists OS 10.8

    and not OS X 10.8.2

    Your phraseology in the last post made me look again.

     

    Does you iMessage Account pane look like this ?

    iMessages account.png

    At OS X 10.8.2 Update the Messages App is updated to version 7.0.1

    This changes the pic above  (the Sign Out and Detail Buttons are no on the "Front" part)

    The Send From Drop down has been added at the bottom.  (You may only get this with Two active "Receive" names/iPhone Numbers)

     

    It used to look like this

    Vers 7.0.png

     

    3Sigcopy2.png
    10:06 PM      Tuesday; February 12, 2013


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • Ralph Johns (UK) Level 9 Level 9 (66,815 points)
    Currently Being Moderated
    Feb 12, 2013 2:38 PM (in response to Ralph Johns (UK))

    4thanx.gif For the Points  2correct.png

     

    I should have also said you need OS X 10.8.2 ( and the Messages Update) and iOS 6 to get the iPhone to Sync the Number as well as the Apple ID

     

     

    3Sigcopy2.png
    10:38 PM      Tuesday; February 12, 2013


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • koolkat Level 1 Level 1 (5 points)
    Currently Being Moderated
    Mar 15, 2013 8:31 PM (in response to Ralph Johns (UK))

    Thanks to Ralph Johns!

     

    I had the problem after 10.8.3 upgrade. My phone # wasnt available on imessage on my macbook pro.

    I tried airplane mode for 5 minutes, nothing, I powered off the iphone for 10 minutes, started it, and a window on my mbp popped up saying phone number added to imesage....

     

    All good now but frustrating! Thanks again, KK

  • vea1083 Level 3 Level 3 (685 points)
    Currently Being Moderated
    Mar 16, 2013 6:45 PM (in response to koolkat)

    koolkat wrote:

     

    Thanks to Ralph Johns!

     

    I had the problem after 10.8.3 upgrade. My phone # wasnt available on imessage on my macbook pro.

    I tried airplane mode for 5 minutes, nothing, I powered off the iphone for 10 minutes, started it, and a window on my mbp popped up saying phone number added to imesage....

     

    All good now but frustrating! Thanks again, KK

    I am going to try your procedure. I too got my number kicked out of iMessages on the Mac (called Messages).

  • Ivan H Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 23, 2013 3:33 AM (in response to vea1083)

    From your iPhone:

    After the Airplane Mode turns ON,

         try turning OFF WiFi and BlueTooth,

              give another 20 seconds, then turn Airplane Mode OFF,

                   give another 60 seconds before logging off iMessage from your Apple ID

                        wait a minute, then log in your Apple ID again.

     

    (Apple's Message Server should be waken up by then).

     

    Now, Sign Out from iMessages Preferences Accounts Apple ID

                   wait a minute, then re- Sign In with your Apple ID and check "Enable this account".

                        You shall see your iPhone mobile number as the first entry under "You can be reached for messages at:".

     

    Does it work?

  • Olyts Level 1 Level 1 (10 points)
    Currently Being Moderated
    Jun 27, 2013 5:42 AM (in response to Ivan H)

    Had the issue, your solution did work for me! Thanks!

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.