Skip navigation

iphoto won't quit, won't import photos, stalls while editing photos despite rebuilding the database

1591 Views 6 Replies Latest reply: Feb 13, 2013 9:05 AM by Old Toad RSS
ajosc Calculating status...
Currently Being Moderated
Feb 12, 2013 9:06 AM

I have mountain lion and the newest version of iphoto.   It won't quit unless I force quit it, it won't import photos, it won't let me edit photos without freezing up.   I have tried rebuilding the database and repairing permissions without success

iMac, Mac OS X (10.7.4)
  • Old Toad Level 10 Level 10 (113,195 points)

    Try this:  launch iPhoto with the Option key held down and create a new, test library.  Import some photos and check to see if the same problem persists. If it freezes also try this:

     

    1 - delete the iPhoto preference file, com.apple.iPhoto.plist, that resides in your

         User/Home/Library/ Preferences folder.

     

    2 - delete iPhoto's cache file, Cache.db, that is located in your

    User/Home/Library/Caches/com.apple.iPhoto folder (Snow Leopard and Earlier).

    home.PNG

    or with Mt. Lion from the User/Library/Containers/com.apple.iPhoto/
    Data/Library/Caches/com.apple.iPhoto
    folder

     

    iP11mtlioncache.png

    3 - launch iPhoto and try again.

     

    NOTE: If you're moved your library from its default location in your Home/Pictures folder you will have to point iPhoto to its new location when you next open iPhoto by holding down the Option key when launching iPhoto.  You'll also have to reset the iPhoto's various preferences.

     

    NOTE 2:  In Lion and Mountain Lion the Library folder is now invisible. To make it permanently visible enter the following in the Terminal application window: chflags nohidden ~/Library and hit the Enter button - 10.7: Un-hide the User Library folder.

     

    If the new library doesn't freeze or act like your current library then your current library is the culprit.

     

    In that case  Apply the two fixes below in order as needed: 

     

    Fix #1

     

    Launch iPhoto with the Command+Option keys held down and rebuild the library.

     

    iP93rebuild.PNG

     

    Since only one option can be run at a time start with Option #3, followed by #4 and then #1 as needed.

     

    Fix #2

     

    Using iPhoto Library Manager  to Rebuild Your iPhoto Library

     

    1 - download iPhoto Library Manager and launch.

     

    2 - click on the Add Library button, navigate to your Home/Pictures folder and select your iPhoto Library folder.

     

    3 - Now that the library is listed in the left hand pane of iPLM, click on your library and go to the File ➙ Rebuild Library menu option.

     

    4 - In the next  window name the new library and select the location you want it to be placed.

     

    5 - Click on the Create button.

     

    Note: This creates a new library based on the LIbraryData.xml file in the library and will recover Events, Albums, keywords, titles and comments.  However, books, calendars, cards and slideshows will be lost. The original library will be left untouched for further attempts at fixing the problem or in case the rebuilt library is not satisfactory.

     

     

    OT

  • Old Toad Level 10 Level 10 (113,195 points)

    The test library was to determine where the problem was.  It's your problems libraruy.Now run the fixes I posted on it.

  • Old Toad Level 10 Level 10 (113,195 points)

    You can merge the two libraries with the paid version of iPhoto Library Manager.  If you have the latest iPhoto and Aperture you can use Aperture to merge the two libraries.

     

    To delete unwanted libraries just drag them to the Trash  bin in the Dock and empty it.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.