Skip navigation

iTunes 10.5.1 Home Sharing not working (Windows 7 64 Bit)

153692 Views 189 Replies Latest reply: Apr 17, 2014 1:55 AM by noahg8 RSS
  • LiquidDragon1 Level 1 Level 1 (0 points)

    I just got an apple TV 3 a few days ago and have been spending the past few days trying to get my home sharing to work with no results.  After almost giving up on it i started looking through the tabs in itunes and went under edit and then preferences and then clicked on sharing and noticed that it said that bonjour was disabled and needed to be enabled for this to work so i google how to enable bonjour and did so and finally my home sharing is now working like a charm.  hope this helps someone else. 

  • Ducktour Level 1 Level 1 (0 points)

    Thank you IIngoc - after waisting hours of search for answers you have found it for me about problems with home sharing adn itunes on PC.

     

    As for the basic guide from Apple, re-start, re-install and turn on home sharing, yes I tried it a hundred times, including turning on of router etc but this trick you have helped me survive.

     

    ATV can now see my computer and more import, itunes now can see my ATV !!!!!

  • dudeman618 Calculating status...

    I had the exact problem, ATV gen3, Windows 7 64-bit, and home sharing stopped working about 2 weeks ago.  I found the post and I turned off IPv6, rebooted and everything is working again.

  • Boiiboii Level 1 Level 1 (0 points)

    I was hopeful at first to know that disabling ipv6 might work but unfortunately it didn't. The home sharing on the left pane still disappears. I dont know what else to do.

     

    Tried restarting the pc doesnt help.

  • undeadrome Level 1 Level 1 (0 points)

    Thank you for this tip, I was ready to smash everything, I've been searching the forums for days now...

  • FixedIt Calculating status...

    Solution!  My issue is that I cannot sustain a home sharing connection between iTunes and my iPhone.

     

    After much frustration and many hours of trawling the forums for a fix, I noticed that if I turned Wi-Fi off and then on again under wi fi settings I could re-establish the connection. This led me to believe that the problem originated not with Apple software but with my Wi-Fi setup.

     

    Disabling Internet Protocol V.6 solution mentioned earlier in the thread seemed to help but did not fix it.  Please note that the below workaround has only been tested with IpV6 unchecked.

     

    The work around I am currently implementing is to place my iPhone ip address in the DMZ of my router. For those unfamiliar with this the method is as follows:

     

    1. give your iPhone a static IP address settings - Wi-Fi - select the arrow next to your network -  make note of the DHCP settings - Select static - enter DHCP settings - Change IP address to 192.168.1.101 - press home button.


    2. place said IP address in DMZ of router - go to internet browser - enter router IP (usually 192.168.1.1) - enter username and password (usually admin & admin by default). - Find DMZ (usually under advanced settings) -  enter static IP address of Iphone (192.168.1.101).

     

    I understand your frustration brothers, I hope this helps.

  • SDBonez Level 1 Level 1 (0 points)

    Finally resolved my issue (Home Sharing stopped working after an iTunes crash  Win7 64-bit).

     

    I had read just about every post on the subject and tried everything to no avail. I finally started doing more isolation and realized that home sharing was still working on my network from other machines to other devices but not from my main library.  I'd fully wiped/reinstalled itunes, bonjour, the various apple services, removed ipv6, you name it.

     

    Finally, in a last ditch effort, I remembered that when my itunes app crashes, it 'checks the library' when it next starts.  Thinking that maybe my library was corrupted (turns out, it was), I went into task manager and ended task on iTunes.

     

    Sure enough, when I restarted iTunes, the 'libary was checked', and voila!  The shared library again showed via home sharing to my various iDevices.  I spent enough time trying everything on this (and I'm no idiot, either) that I registered just to make this one post - hope it helps someone else.

     

    Cheers,

    SDBonez

  • sayuss Level 1 Level 1 (0 points)

    Hi,

     

    have you tried to end process "APSDaemon.exe" in Windows Task Manager?

    1) Quit Itunes

    2) Open windows task manager to see running processes

    3) Find and select "APSDaemon.exe", end this process.

    4) Run Itunes and check

     

     

    Windows 7 64-bit

    Remote App

  • VAMresh Calculating status...

    For all those who are still facing this issue, I have a question. In yout iTunes application, do you see your Apple TV as an AirPlay device?

  • Forgotten Rebel Level 1 Level 1 (0 points)

    Hmmm, Mine itunes says sharing is on with no warnings at all. It will work for about a minute then it stops and I can never get the airplay icon to show up in itunes either, I can only airplay my ipad, iphone to ATV3 but not my main itunes PC that runs the whole home network.

     

    No usable home sharing and no airplay icon shows up in my itunes 10.7.0.21 / Win 64 bit pro.

  • LiquidDragon1 Level 1 Level 1 (0 points)

    just got a new Linksys AE4500 router and sure enough my homesharing didnt work again but thanks to llngoc your suggestion to disable the IPv6 adapter worked.  Oh and i am now on iTunes 11 now and wishing i was still at version 10

  • ckuan Level 6 Level 6 (19,835 points)

    Turn on In iTunes menu > View > Show Sidebar and you should be alright.

  • Orest75 Level 1 Level 1 (0 points)

    Thanks This worked for me.  I have had no interuptions with my ATV since I made these changes.  Now if I can only get my wifi sych to work.  Any suggestion on that?

  • Taliesin121 Level 1 Level 1 (0 points)

    I had this problem and found the problem was the technicalities of being on the same network.... itunes recognized my wired and wireless network as different networks... i simply changed all of them to wireless and it works fine... or if you wanted you could put all of the computers onto the same wired network.

    So to break it down my wired laptop could see the librabry of the wireless computer but not the other way around... after switching my wired laptop onto wireless instead the problem was fixed and both computers could now home share and see each other.

    Hope this helps.

  • undeadrome Level 1 Level 1 (0 points)

    With:

    Windows 8

    Itunes 11

    ATV 3

    Verizon Router MI424WR

     

    I have done these things in order to get Home Sharing to work

     

    First solution was to turn off IPv6

    Second was to turn off IGMP Proxy in the routers advnced setting

    Third was to swicth my network type to "Broadband" in the advanced wireless options within the router

     

    All of those solutions worked individually for a period of time until either itunes or the ATV was updated.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (16)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.