1 2 Previous Next 20 Replies Latest reply: Feb 15, 2013 10:47 AM by SwankPeRFection
laurenpheale Level 1 Level 1 (0 points)

For some reason my Imessage is not working on my Macbook Pro but it works on my phone.
Is anyone else's not working ??


MacBook Pro
  • 1. Re: My Imessage on my Macboookpro is not working
    gail from maine Level 6 Level 6 (11,545 points)

    Maybe you could be a little more specific about what "not working" means?

     

    GB

  • 2. Re: My Imessage on my Macboookpro is not working
    laurenpheale Level 1 Level 1 (0 points)

    I get this message when i try to log in The server encountered an error processing registration. Please try again later and it has been like that all day !

  • 3. Re: My Imessage on my Macboookpro is not working
    gail from maine Level 6 Level 6 (11,545 points)

    What have you tried to resolve it? Have you rebooted your Mac?

     

    GB

  • 4. Re: My Imessage on my Macboookpro is not working
    laurenpheale Level 1 Level 1 (0 points)

    Yes I have several times. on my Imessage on my mac it says stuff about AOL ? but i don't even have AOL so why would IMessage have AOL on it ? and i can't even log into that for some reason. It's just really frustrating because i never had problems with it before.

  • 5. Re: My Imessage on my Macboookpro is not working
    gail from maine Level 6 Level 6 (11,545 points)

    It says stuff about AOL where, specifically? You are going to have to try to be a little more specific...I can't see your Mac, so when you say on your iMessage on your Mac, I have no clue what you are referring to....Preferences, iMessage new message? And what do you mean "it says stuff about AOL"? What do you mean "it says stuff...."?

     

    I can't help you if you don't provide me with very specific, very clear information....

     

    GB

  • 6. Re: My Imessage on my Macboookpro is not working
    SwankPeRFection Level 4 Level 4 (1,435 points)

    On your iPhone, go to Messages and make sure you add an email address to the available account to use iMessage with (it cannot be just your phone number initially).  Most people will use the same email address that's their AppleID.  Once you've done this, then go to your MacBook and start iMessage.  Log in with this same email address and password.  Once you've done that, you can now either continue to use just that email address, or change it to use the iPhone's phone number as well.  If you do this correctly, all your iMessages that come to your phone will also go to your MacBook, etc.

  • 7. Re: My Imessage on my Macboookpro is not working
    laurenpheale Level 1 Level 1 (0 points)

    I had my e-mail on my phone but it only shows my phone number.. and i use my hotmail acccount for my apple ID ... but when i try to log into imessage on my laptop.. it first comes up with an AOL like this.. Screen Shot 2013-02-13 at 7.13.53 AM.png

    and i don't have anything to do with mac.. and i switch over to like my Imessage account.. and i still get the same error message. I have changed my Appple ID password several times and nothing.. I get Imessage on my phone still but nothing on my computer!

  • 8. Re: My Imessage on my Macboookpro is not working
    SwankPeRFection Level 4 Level 4 (1,435 points)

    Did you enable AOL IM as one of the account options in Messages?

     

    Go into the Messages program and then go into Message/Preferences off the menu.  Go into Accounts and delete the AOL one from there.  If you didn't accidentally add one, it wouldn't ask you for a password for one.  Also, you might want to just delete all accounts you have set in there and start from scratch to set it up like I told you to in the other message.  You have to pick an email address to use (i.e. AppleID one) on your phone before you can set this up to work on your Mac.  The Mac cannot use a phone number initially because there's no way to sign in with a phone number.

  • 9. Re: My Imessage on my Macboookpro is not working
    laurenpheale Level 1 Level 1 (0 points)

    I can't delete me apple ID on my imessage. Since you told me to delete everything it won't let me.

  • 10. Re: My Imessage on my Macboookpro is not working
    SwankPeRFection Level 4 Level 4 (1,435 points)

    OK, but it should have let you delete the erroneous AOL IM account listing though, right?  Were there any other accounts other than your AppleID one listed there?

  • 11. Re: My Imessage on my Macboookpro is not working
    laurenpheale Level 1 Level 1 (0 points)

    Yes that it did let me delete that account.. and then i left it alone for awhile and created a new Apple ID but it still won't let me log in !

  • 12. Re: My Imessage on my Macboookpro is not working
    SwankPeRFection Level 4 Level 4 (1,435 points)

    Why are you creating a new Apple ID?  That's not necessary.  You need to go into Messages ON YOUR IPHONE under settings and add your AppleID as another account you can use with iMessage.  Once you've done that and confirmed the change, then go back to the Mac and sign into Messages on that with the AppleID you associated in the Message settings on your iPhone.  You'll get a message on the iPhone that a new device was associated with iMessage (i.e. your Mac) and it'll work from then on.

  • 13. Re: My Imessage on my Macboookpro is not working
    laurenpheale Level 1 Level 1 (0 points)

    Yeah i have tried that and i never got a message on my my iPhone that a new device is associated with iMessage.

  • 14. Re: My Imessage on my Macboookpro is not working
    SwankPeRFection Level 4 Level 4 (1,435 points)

    OK, let's do this step by step.

     

    Grab your iPhone.

     

    Go to Settings/Messages/Send&Receive.

     

    Unassociate your AppleID from this screen and delete ANY emails in there associated with it.  Make sure the only thing left is your phone number and it is checkmarked.  Then back out of those settings screen utilizing each of the buttons on the top left of the screen until you're back under settings.  Then turn off the iPhone by holding down both your Home and Power buttons until the iPhone turns off (DO NOT Slide to Turn Off).  Then turn it back on and wait for it to come back up and link up the network.

     

    Go back into Settings/Messages/Send&Receive and click on Add Email.  Put in your AppleID info on the next screen.  (DO NOT create a new AppleID).  Confirm this info and then make sure on the previous screen that the email address is set as the one with the checkmark next to it.

     

    Then back out of the settings screen utilizing the back buttons each time.

     

    Go to your Mac and Quit out of Messages.  Start the app back up and sign in with the SAME AppleID and password you just used on your iPhone.

     

    If you do this right, it will work.

     

    BTW, make sure you're connected to the web on your Mac when you're doing this... but that should be pretty obvious that you need that layer of connectivity.

1 2 Previous Next