Skip navigation

Unable to Connect to Network Printer

5431 Views 43 Replies Latest reply: Apr 14, 2013 8:05 AM by Samir Sogay RSS
1 2 3 Previous Next
DhruvC Level 1 Level 1 (80 points)
Currently Being Moderated
Feb 12, 2013 5:12 AM



I am trying to install Samsung ML-1640 through my wireless router's print server feature but its not working. Whereas I am able to print through my Windows PC's on the network with no issues.


On giving print command the print job is getting paused around 40-50% in the print que and not printing. Neither the printer is getting pinged through Network Utility.


The printer is work fine with my MBP 13' when attached directly through its USB port.


1) Have tried deleting & re-adding the printer through its IP with all the three different protocols LPD, IPP & HP JetDirect.


2) Have updated to the latest drivers from here:


3) Also, have gone through the troubleshooting steps given in this article:

MacBook Pro (13-inch Late 2011), OS X Mountain Lion
  • PAHU Level 6 Level 6 (14,400 points)
    Currently Being Moderated
    Feb 12, 2013 11:57 AM (in response to DhruvC)

    Since Windows is working you should check what protocol and queue name it is using. You can see this information under the Ports tab after selecting Properties. Then you can press the Configure Ports button to see this information. Once you see the protocol and queue used, you can then use this information for the Mac.


    Also note that some vendors drivers for OS X have limitations compared to the Windows driver for the same printer. One of these limitations is when the printer is connected to the USB port of a wireless router. If this is your setup then you may have all the correct network information set and it is the driver that is causing your problem.

  • PAHU Level 6 Level 6 (14,400 points)
    Currently Being Moderated
    Feb 13, 2013 2:43 AM (in response to DhruvC)

    The second image shows that Windows is using IPP for the protocol. So you could create the queue on the Mac using the same protocol, but you must enter the correct information as shown in Windows.


    Enter the IP address of the router (

    Select IP > IPP for the protocol.

    Enter the queue name as printers/SamsungML1640

    Then select the ML1640 driver in the Use menu


    As for the HP Jetdirect protocol, you could use this but you would need to enter queue information for the USB port. This could be something like Port1 or even a port number, like 9101. You would need to check the documentation for the router/print server.

  • PAHU Level 6 Level 6 (14,400 points)
    Currently Being Moderated
    Feb 14, 2013 12:13 AM (in response to DhruvC)

    The log shows that the destination is "". This would suggest that the DNS name used by is your MacBook Pro rather than the print server. So you may want to check all the IP addresses that are being provided by the router.

  • PAHU Level 6 Level 6 (14,400 points)
    Currently Being Moderated
    Feb 14, 2013 2:22 AM (in response to DhruvC)

    This looks correct. The router is your local DNS server so the entries shown above are okay. Don't be concerned about having two entries.


    Can you confirm what the name of your Mac is. This can be found in the Sharing > File Sharing preference pane.


    What you need to look at is the addresses allocated by the router. If you open a web browser on the Mac and type



    and press Return, this should take you to the internal web page of the router. You will probably need a password to get past the home screen. Once you are in you should see an entry about what IP addresses have been given out and what computer names are using them.


    What you can also try with the web browser is typing in



    and press Return. This should show the shared printer (the Samsung). Do you see this?

  • PAHU Level 6 Level 6 (14,400 points)
    Currently Being Moderated
    Feb 14, 2013 3:04 AM (in response to DhruvC)

    Did you just enter in Network Utility or did you enter ?


    If you entered just the IP address in Network Utility then it would suggest that you have this complete address registered in your Hosts file. This file is located in the hidden folder etc. The easiest way to access the file is to open Finder and select Go > Go to Folder. Then type /etc and press Go. This will take you to the hidden etc folder and here you should see a file called hosts. You can double-click on the file - it should open up in TextEdit. Do you see an entry with the address?

  • PAHU Level 6 Level 6 (14,400 points)
    Currently Being Moderated
    Feb 14, 2013 2:44 PM (in response to DhruvC)

    Okay, you cannot ping the http address. The correct action is just to ping the IP address, which when you did it showed you are getting a response.


    What I was concerned about was that you pinged and got the response of Ping cannot resolve the http address. Anyway, this was not the case. You were just doing the wrong thing so all is good.


    The thing that still concerns me is that when you try to print you get this message in the cups error log


    E [14/Feb/2013:13:03:10 +0530] [Job 1] Unable to queue job for destination "ipp://abc-macbook-pro.home/printers/Samsung_ML_1640".


    This suggests that your Mac is trying to connect to itself rather than the router, which is why it errors. So why does the Mac try to send the print job to itself. Hopefully it is due to you creating the queue incorrectly. To check, can you open System Information and select Printers in the left column. Then select this Samsung printer in the right pane. Can you copy this information and paste back here for me to check.


    Also, what brand of router do you have that the Samsung is connected to? I would like to find a manual for it and check what is says about adding a USB connected printer on OS X.

  • PAHU Level 6 Level 6 (14,400 points)
    Currently Being Moderated
    Feb 16, 2013 2:32 AM (in response to DhruvC)

    I downloaded the DSL-2750U manual today. Unfortunately there was not one shred of information about configuring a USB connected printer. In fact the manual does not even state that it supports such as connection. The only reference it makes to the USB port is for connecting another computer.


    Do you have a guide that came with the router explaining how to add a USB connected printer? Maybe there is an explanation of what protocols it supports and how to add a printer on OS X?


    If not, then the latest information you have provided above looks correct - at least when comparing it to what Windows is using. So if this queue is not printing from the Mac then maybe it is due to the Samsung driver.

1 2 3 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.