7 Replies Latest reply: Feb 14, 2013 4:37 PM by mkjt88
mkjt88 Level 1 Level 1 (0 points)

I have a MBP running Mountain Lion 10.8.2 connected to Mediacom using their standard Netgear modem and it constantly loses wifi signal. Every other device stays connected at all times so I know it's just the computer. It started awhile back and has gotten to the point where I can't seem to do anything without having to turn the wifi off and reconnect. This sometimes solves the problem I usually have to do that 2-3 times before it works. Sometimes it may last 20-30 min but some rare occasions it will only load one webpage for a min or two. This is getting very annoying and has made any video streaming a no go. I've ran diagnostics done everything I could its all good... a ghost problem for me.. Any help?


MacBook Pro, OS X Mountain Lion (10.8.2)
  • 1. Re: Wifi Disconnect Problem - Drops Constantly
    mkjt88 Level 1 Level 1 (0 points)

    Any thoughts on this? I've done a bit of research and seen something about some settings needing changed that may fix but can't find anything solid that walks me through how to do anything.... Anyone?

  • 2. Re: Wifi Disconnect Problem - Drops Constantly
    SwankPeRFection Level 4 Level 4 (1,435 points)

    Problem could be because that router is using both b/g and n network technologies.  Some Mac systems tend to have an issue with routers or access points that can do b/g/n on both 2.4GHz and 5GHz.  Either put your 2.4GHz radio to b/g and leave the 5GHz one at a/n or if that's not an option, just flip your WIFI to be just b/g and see if it's any better.

  • 3. Re: Wifi Disconnect Problem - Drops Constantly
    mkjt88 Level 1 Level 1 (0 points)

    Hi Swank.. I'm not sure how to do this.. I got on my settings and turned my 300Mbs to the setting below it.. i think 140 or something I'm not positive.. It seems to have helped.. It lasts longer this way to ultimately it still goes out and I have to turn it off/on to get it to work again. How would I do what you suggested?

  • 4. Re: Wifi Disconnect Problem - Drops Constantly
    SwankPeRFection Level 4 Level 4 (1,435 points)

    What's the model number of that router you have from Mediacom?  Usually the settings allow for speed settings on the bands and generally speaking, you can drop the N band down to 140 from the max of 300 and that can help, as you've seen, but if that doesn't help entirely, dropping it to 54Mbps would bring you down to 802.11g speeds.  The thing is, it's not the speed that causes this issue sometimes, it's the frequency, so it would be best to flip the radio from 802.11a/b/g/n to 802.11b/g if possible as a test.  If you can tell me the model number I could possibly find more info on what exactly the screen looks like... unless you feel like taking a screen capture of it and posting it on here as long as it doesn't have any personal info on it (account name, number, etc.).  I could then tell you what setting to change based on what I see in your pic.

  • 5. Re: Wifi Disconnect Problem - Drops Constantly
    mkjt88 Level 1 Level 1 (0 points)

    Netgear CG3000D

  • 6. Re: Wifi Disconnect Problem - Drops Constantly
    SwankPeRFection Level 4 Level 4 (1,435 points)

    Wow, that thing's got some pretty basic controls in it. lol

     

    Here's the manual for it.  NETGEAR Cable Modem Gateway CG3000D-1CHXAS User Manual

     

    Go ahead and drop that speed level one more to below the 145 mark that it's on now and see if that stabalizes your connection.  Also, make sure you're using WPA2/AES for your security on it.  There should be no issues with 145 speed, but 300 could cause your disconnects you're seeing.  Try 54 and see what happens long term.

  • 7. Re: Wifi Disconnect Problem - Drops Constantly
    mkjt88 Level 1 Level 1 (0 points)

    Seems to have fixed it.. Thank you very much