Skip navigation

Canon Camera not Mounting

55956 Views 36 Replies Latest reply: Oct 17, 2013 7:45 PM by philsampson RSS
  • myth0s Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 13, 2012 4:02 PM (in response to J D McIninch)

    JD, that was an excellent, informative answer, thank you!

     

    It would be great if there was a plugin for the Finder to show Picture Transfer Protocol (PTP) devices.

     

    I am fine using Image Capture to transfer the photos and movies off of the SD Card, but it is less convenient than manually manipulating the SD card (for me). And I definitely do not want Yet Another Device like a USB card reader to deal with. The camera itself ought to be sufficient as a reader.

  • Kimm Tynan Calculating status...
    Currently Being Moderated
    Jan 13, 2013 10:23 PM (in response to Francine Schwieder)

    Thank you so much!  I had hundreds of photos on my Rebel that I have not been able to download for the longest time, I was afraid they were lost forever. I used Image Capture and, admittedly after lots of futzing around, they are now safely downloaded.  Hooray!

  • Jay Warner1 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Jan 17, 2013 10:57 PM (in response to f0rgiven)

    Clearly, I am not alone in wondering how Canon image files get onto my machine.  My solution was to bypass the camera aspect – I bought a 'universal' card reader for relatively few bucks, and it always mounts the chip as a USB 'device' that automatically invokes LightRoom or iPhoto, as I specify in the prefs. 

     

    I have since added two more Canon point-and-shoot cameras, and both of them behave the same way.  They must all use the PictureTransfer Protocol (PTP) (thanks, J D McIninch, for the info), since they do _not_ show up as mounted devices.  When I do not use the universal card reader, I attach the camera, wait a while, then tell LightRoom to import; it finds the correct files.  _Sometimes_ it will find them automatically, but I'm never sure if it will.

     

    Meanwhile, I recommend that you use a good cable (as per Csound1), and a card reader, or simply wait 2X as long as usual for mounting USB devices, then proceed with your choice of photo software.

  • atmatm Calculating status...
    Currently Being Moderated
    Feb 14, 2013 2:28 PM (in response to AmySellsAlabama)

    I am having the same issue.  I have a 2009 canon eos rebel xti and a brand new 2013 imac ios mountain lion, and the imac does not even see the camera. this camera was not cheap.  This just adds up to time and money wasted. So fustrating.  But my cheap 2008 canon pocket camera is seen by the imac. go figure.

  • atmatm Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 14, 2013 2:35 PM (in response to atmatm)

    OMG, I saw some advicce a few posts up that said: "use the same usb cable that came with your camera"  Luckily I am an organized packrat, found the white usb cable, and all the new pics from the rebel xti are there on my imac. The usb from my cheap pocket powershot canon (which i always used to use for both canon cameras) although works for the powershot, does not work with the eos rebel xti.

  • atmatm Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 14, 2013 2:41 PM (in response to raylina)

    My USB cable that came with my 2009  canon eos rebel xti is allowing me to view pics from the camera on my 2013 imac.  The USB that came with my 2008 canon power shot does not allow me to access the files on the rebel xti.  On my old imac from 2009, the cheap USB worked for both cameras, but not anymore.  This forum really helped. I would never have thought to try a different USB. THANKS!

  • philsampson Calculating status...
    Currently Being Moderated
    Oct 17, 2013 7:45 PM (in response to f0rgiven)

    Running 10.4.11 OS, so software included with my T3i won't install (wants 10.5) - however, the image capture solution works for me! Thanks so much! As an aside, card reader came with my SD card and while the system recognizes the device and even gives it a name, the thing won't mount or in any way perform as it should.

1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.