Skip navigation

File in use by Finder

4619 Views 22 Replies Latest reply: Jan 17, 2014 1:57 PM by Walther Schoonenberg RSS
  • John Allen2 Level 1 Level 1 (35 points)
    Currently Being Moderated
    Apr 21, 2011 5:59 AM (in response to ublue)

    I see over at this thread: http://forums.adobe.com/message/2479648

     

    An Adobe employee said:

     

    Adobe has done what we can (and we're still trying to find other ways around it, like trying again after half a second) - but the files are being locked by something OUTSIDE our control.

    We've notified Apple about it, and they have made several fixes over the years - but somehow the problem keeps recurring in their software.

     

    No, this does not come up just in Photoshop.  It happens in any application that actually checks for errors when saving the file.  But there are many applications that don't check for such errors.

     

    Correct, this problem should not exist.  But all we can really do is tell the user when it does occur.

  • Allegra_man Calculating status...
    Currently Being Moderated
    Jan 10, 2012 12:41 PM (in response to John Allen2)

    I am glad I found this, because I have been experiencing the same problem.

  • darondavis Calculating status...
    Currently Being Moderated
    Jul 20, 2012 2:14 PM (in response to Allegra_man)

    I've been having this problem for a bit and couldn't figure it out, it was driving me a little crazy.

     

    Like has been said, anytime I export a PDF from InDesign that I wanted to copy over a previous PDF, I would get the "file in use" or "you don't have permission" error.

     

    I think I fixed it, try this and see if it helps.

     

    When exporting from InDesign I had the option selected to "View PDF after Exporting"

     

    So when it completed the export, the PDF would auto open in Preview.

     

    Then when I went back to re-export, it seemed that even if I had closed Preview, InDesign or OSX felt like the file was "still in use"

     

    If I turn off that "View PDF after Exporting" option then I seem to be able to save over the original as much as I'd like.

  • plisvb2 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 6, 2012 5:29 AM (in response to ublue)

    Just started having thei issue with InDesign and CS5 after upgrading to Mountain Lion.

     

    Found and app that tells you which program is locking the file in question (http://www.hamsoftengineering.com/products/wkm/wkm.html) and the result is definately the finder, then it shows the process ID, then it says cookied.

     

    Does "cookied" shed any light on this.

     

    Peter

  • deejson Calculating status...
    Currently Being Moderated
    Feb 14, 2013 3:31 PM (in response to plisvb2)

    Would love to know if a solution has been found to this problem.

  • Walther Schoonenberg Calculating status...
    Currently Being Moderated
    Jan 17, 2014 1:57 PM (in response to deejson)

    For some reason Apple won't want to solve this problem. In Mavericks this annoying bug is still there.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.