Skip navigation

My Macbook's new battery is not charging!

361 Views 3 Replies Latest reply: Feb 15, 2013 5:15 PM by dms00 RSS
ShahdQ Calculating status...
Currently Being Moderated
Feb 14, 2013 1:17 PM


I have a Macbook white 13-inch, Mid 2010


A month ago, the taskbar told me that my battery is not chaging, (Replace Now) and the computer would shut down the second the power adapter is unpluged.


so I baught a new battery and installed it but it didn't work and it still says (Not Charging).


I've already tried resetting SMC and nothing changed.


Help me with this PLEASE!




These are the Power info from "About This Mac":


Battery Information:


  Model Information:


  Manufacturer:          SMP

  Device Name:          bq20z451

  Pack Lot Code:          0

  PCB Lot Code:          0

  Firmware Version:          103

  Hardware Revision:          000a

  Cell Revision:          130

  Charge Information:

  Charge Remaining (mAh):          312

  Fully Charged:          No

  Charging:          No

  Full Charge Capacity (mAh):          5273

  Health Information:

  Cycle Count:          1

  Condition:          Normal

  Battery Installed:          Yes

  Amperage (mA):          0

  Voltage (mV):          11043


System Power Settings:


  AC Power:

  System Sleep Timer (Minutes):          5

  Disk Sleep Timer (Minutes):          0

  Display Sleep Timer (Minutes):          5

  Wake on AC Change:          No

  Wake on Clamshell Open:          Yes

  Wake on LAN:          No

  Current Power Source:          Yes

  Display Sleep Uses Dim:          No

  PrioritizeNetworkReachabilityOverSleep:          0

  RestartAfterKernelPanic:          15

  Battery Power:

  System Sleep Timer (Minutes):          10

  Disk Sleep Timer (Minutes):          10

  Display Sleep Timer (Minutes):          2

  Wake on AC Change:          No

  Wake on Clamshell Open:          Yes

  Display Sleep Uses Dim:          Yes

  Reduce Brightness:          Yes

  RestartAfterKernelPanic:          15


Hardware Configuration:


  UPS Installed:          No


AC Charger Information:


  Connected:          Yes

  ID:          0x0100

  Wattage (W):          60

  Revision:          0x0000

  Family:          0x00ba

  Serial Number:          0x00615f25

  Charging:          No

MacBook, Mac OS X (10.7.5)
  • Mike Sombrio Level 6 Level 6 (9,095 points)
    Currently Being Moderated
    Feb 14, 2013 4:55 PM (in response to ShahdQ)

    Forgive me but I have to ask, your MacBook has an integrated battery correct? Is this exactly how you reset the SMC?


    Newer Mac portables with a battery you don't remove

    Shut down the computer.

    Plug in the MagSafe power adapter to a power source, connecting it to the Mac if its not already connected.

    On the built-in keyboard, press the (left side) Shift-Control-Option keys and the power button at the same time.

    Release all the keys and the power button at the same time.

    Press the power button to turn on the computer.  

    Note: The LED on the MagSafe power adapter may change states or temporarily turn off when you reset the SMC.


    Try resetting the pram also, don't know if it'll help but it won't hurt.

    Resetting NVRAM / PRAM

    Shut down your Mac.

    Locate the following keys on the keyboard: Command (⌘), Option, P, and R. You will need to hold these keys down simultaneously in step 4.

    Turn on the computer.

    Press and hold the Command-Option-P-R keys before the gray screen appears.

    Hold the keys down until the computer restarts and you hear the startup sound for the second time.

    Release the keys.

  • dms00 Calculating status...
    Currently Being Moderated
    Feb 15, 2013 5:15 PM (in response to ShahdQ)

    I had the exact same problem with my Early 2011 Macbook Pro. I put a new battery in and it continued to say "Not charging" and simply refused to charge the new battery. It did recognize the battery, and runs off battery, but would not charge it.


    After spending a day searching online and trying everything anyone suggested, I found a solution for me that I haven't seen documented anywhere. Here it is:


    shut down your macbook pro.

    unplug the magsafe from the laptop.

    press and hold the power button for at least 5 full seconds.

    you should see the white light in front start to flash quickly.

    when it's done flashing, release power button.

    if laptop isn't starting to boot now, then press power to turn it on (don't plug in the power cord yet)

    Once it has booted to login screen, plug in power cord.


    It will initially be green, then turn amber after a few seconds.


    Hope this works for you.


More Like This

  • Retrieving data ...

Bookmarked By (1)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.