5 Replies Latest reply: Aug 10, 2013 3:28 PM by JoeSkydiver
CapWkidd Level 1 Level 1 (0 points)

I wanted to move my reference (original files) from a network RAID (readynas) to a new Drobo 5n, so I clicked on photos, selected all, and then used relocate originals.... Many times I got a message saying the original could not be found, while this made the process take days instead of hours, because Aperture would stop every time, and did not have an option to just skip that error if it came up again. I was not concerned with this message, because I know I had some missing masters. This only really seemed to happen for less than 100 images. The real issue, is now, when I try "show in finder", the location for the file has the network address doubled up...

Screen Shot 2013-02-15 at 8.08.11 AM.jpg

 

See how it says /Volumes/Drobo5N/drb125201a00085/1/media, then repeats the Drobo5N/drb125201a00085/1/media part? What is up with that, and how do I fix it?

 

Aperture can not find the originals now, because the network address is wrong, and this is the case for every image I have checked so far.


Mac Pro, Mac OS X (10.7.3)
  • 1. Re: Aperture has has wrong network address for original files....
    Nealf Level 1 Level 1 (50 points)

    I am having similar problems.  Did you ever find a solution?

  • 2. Re: Aperture has has wrong network address for original files....
    heff_sf Level 1 Level 1 (70 points)

    Hi CapWkidd-

    Are you able to view your referenced photos by accessing the Drobo 5n directly in the Finder? If your files are on the new disk you can instruct Aperture to properly link to the new location using File > Locate Referenced Files...  First select all of the missing/unlinked images you want to re-connect, then choose File > Locate Referenced Files:

    locateRef.jpg

     

    In the subsequent dialog select one of the missing images from the top portion of the window. In the bottom portion, navigate to that image in its new location on the new Drobo, then click Reconnect All. Aperture will use the location of that image to update its other missing references.

    locateRef_reconnectAll.jpg

     

    You may need to repeat this process several times.

  • 3. Re: Aperture has has wrong network address for original files....
    Nealf Level 1 Level 1 (50 points)

    I have tried this with my files. Oddly enough, Aperture knew the correct location for the photos. When I tried to update the location, Aperture worked at it forever and never did complete the update.

  • 4. Re: Aperture has has wrong network address for original files....
    Nealf Level 1 Level 1 (50 points)

    I think there is something about the way the Drobo indexes and stores the files. I am having similar problems with my Drobo 5N, so I took it off the network and connected the Drobo 5N directly to a computer via an ethernet cable.  I created some test files and folders and put them on the Drobo and accessed them with Aperture.  If I am accessing a file directly on the Drobo, it worked fine. But Aperture repeatedly failed to find referenced files on the Drobo 5N

     

    On the other hand, when I move the referenced files back to an internal or external drive, then Aperture works fine. As a test, I created a sparse disk bundle on the Drobo 5N and transferred referenced files onto it. Then Aperture works great. The sparse bundle ensures that my referenced files are stored in a file system in a way Aperture can find them. Nonetheless, this is not a viable workaround because of the slowdown with the sparse bundle.

  • 5. Re: Aperture has has wrong network address for original files....
    JoeSkydiver Level 1 Level 1 (0 points)

    Did you have any luck solving this?  I am having the exact same issue with the duplicated drobo address and not being able to find the referenced files.