Skip navigation

Strange Permissions problem when creating new Open Directory user

107 Views 0 Replies Latest reply: Feb 15, 2013 9:44 AM by coiner22345 RSS
coiner22345 Calculating status...
Currently Being Moderated
Feb 15, 2013 9:44 AM

I just set up a mac lab to authenticate to an Open Directory server which also stores home folders. All of the initial users I created work fine, there were about 50 users that I set up. When I added a new user this morning though, it would not allow him to access anything within his home folder (i.e. nothing worked)

 

I went back to the server and took a look at the Users share and noticed that when his accound was created, instead of setting the owner of the folder to his username (xxx123) it was set to his userid number (1024). I did a chown on his directory to his username and he was then able to access his home directory from the clients.

 

I realize I found a fix, but I would prefer to not have to do this every time I create a new user. Why is this happening?

iMac, OS X Mountain Lion (10.8.2)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.