Skip navigation

My brand new 7th gen. iPod Nano has gone COMPLETELY dead

5961 Views 10 Replies Latest reply: Apr 3, 2014 6:08 PM by JParbo RSS
Dr. Planarian Level 1 Level 1 (0 points)
Currently Being Moderated
Feb 15, 2013 12:44 PM

My brand new (February 2; it is now February 15) seventh generation iPod Nano has gone completely dead.  Its battery should be fully charged.  It has no response of any kind, whether plugged into my computer or not.  It just has a totally black screen and no sound comes out through the earphones.  It does not even show the "connected" screen when plugged into my computer.  I suppose I must return it for a replacement, but is there any method short of that by which I might revive it?

iPod nano, Other OS, iPod nano is 7th gen. O/S is Win 8.
  • John Scott1 Level 2 Level 2 (300 points)

    Interesting that you have this problem too. I went to listen to mine one day and got a flickering screen a couple times then it went blank. I could connect to my PC and it would do a restore but I could not get it to display anything. I called Apple and was all set to send it back for warranty and it sat a couple days and then I received the box to send it back. I tried one last time to see if it was still dead and it turned on. Funny thing was the screen was now in German and not English? After I got that worked out the darn thing has worked perfectly?

    I have 10 days to decide before the box label is void. Trying to figure out what happened?

  • Russell Chea Level 1 Level 1 (20 points)

    i'm going to ask you to try something I just did to fix a maybe simular problem that worked..... but I don't know why yet........make sure your iPod in plugged into your computer (mine is a Mac) and iTunes is turned on. My iPod  was  also "dead" but had been plugged into my computer for a couple of hours (but not lit up in any way).  Then (in desperation) I held down all the buttons, the on/off (on top right), the small Home botton at the bottom of the face, and the volume/pause buttons (left side).  For whatever reasons my iPod came back to life in a needs restoring mode ....and asked me to restore it in the itunes like "new'  iPod connected mode.  Since I have a Mac I also had to give permission to do a download by entering my computer password. If you have to do the same have that password ready. Then it did a restore software download.  Everything previously on the iPod was erased and had to be re-synced,  but I was just thankful to get it up and restored again.

     

    Give this a shot and I hope it works for you.....but  why? I don't know yet, I need more questions answered.

  • bongzki_02 Level 3 Level 3 (615 points)

    Do the reset. Press and hold the on/off and home buttons until apple logo appears. This normally happen when ipod is left to charge or not used for a long period of time. Cheers!

  • Nico0o Level 1 Level 1 (0 points)

    Thanks bud. it worked!

  • ___Saby___ Level 1 Level 1 (0 points)

    wow, it worked! Why is that normal? Mine, which is like 2 weeks old, went black (being fully charged) while I was listening some music. I just tried this on/off and home button combination and its alive again... should I consider getting a new one or this ir really normal and will help every time if that happens again? Ok, i could believe that this button combination is "normal" and made exactly for this kind of cases, but why ipod going totally dead while im listening to my music would be normal? being fully charged...weird

  • SeekEyes Level 1 Level 1 (0 points)

    Two day old, brand new Nano 7th Gen, same issue. Thanks for the Fix!

  • Nooa Level 1 Level 1 (0 points)

    It worked for me too, thanks!

  • 1994Bobcat Level 1 Level 1 (0 points)

    Christmas present - dead this morning (12/26) - read this thread, tried the "All-Button-Hold" and it's revived!  Anyone know why?  Anyone continued to have problems or is this a one shot deal and we're good to go?  Thank you one, and all! 

  • JParbo Level 1 Level 1 (0 points)

    As with several others, mine was brand new.  I left it to charge overnight and the next day it appeared dead as a doornail.   Rebooting it by pressing the home button on the bottom front along with the power button on the top right at the same time caused it to power on and now it is behaving normally.   I would love to know if this suggests I am going to have further trouble.  I have this 7th gen model because the power buttons on two 6th gen models failed (just outside of the warranty periods).   Thanks to all who helped with this issue.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.