1 Reply Latest reply: Feb 15, 2013 6:11 PM by randers4
sharon230 Level 1 (0 points)

Hi, my husband & I both have iphone 4's which have been great up until recently when i was given an ipad for Xmas.

I have set up icloud on my Mac, iphone & ipad but find that when i send or receive a message my husband also gets a copy of this on his phone which is a pain. His phone was set up under my apple id when we first purchased them. If i register him for his own apple id how do i change this on his phone???? & will i still be able to sync both phones on my Mac so that i only have to purchase songs, apps etc once.


Mac Pro, Mac OS X (10.6.8)
  • randers4 Level 9 (62,715 points)

    This happens when you both use the same Apple ID for iMessage, and can be fixed in one of two ways:

     

    1. On his phone, go to Settings>Messages>Send & Receive, tap the ID, sign out, then sign back in with a different ID.  Note: you can continue to share the same ID for purchasing in Settings>iTunes & App Stores; or
    2. On all your devices go to Settings>Messages>Send & Receive and uncheck the email address(es) shown under "You can be reached by iMessage at".