Skip navigation

SSD in PPC G5 2.3 ghz

1145 Views 9 Replies Latest reply: Feb 16, 2013 7:20 PM by DwainC RSS
DwainC Level 1 Level 1 (20 points)
Currently Being Moderated
Feb 15, 2013 3:11 PM

Just curious... Just recently purchased a newer 2.3 g5 and decided to pick up a Samsung 840 ssd. The PowerMac would only recognize the SSD on the slave bus even after the ssd had been initialized and formatted with a fresh os install.

 

Any Ideas??????????

G4, G5, MacBook, Mac OS X (10.5.6), Dual 500, dual MacPro, MacBook, RD, VMware, Intel Vista
  • BDAqua Level 10 Level 10 (114,670 points)
    Currently Being Moderated
    Feb 15, 2013 5:26 PM (in response to DwainC)

    Is it SATA 1.5 Gb/s compatible?

  • japamac Level 7 Level 7 (24,390 points)
    Currently Being Moderated
    Feb 16, 2013 3:51 AM (in response to DwainC)

    Master/Slave don't really apply (not being "snarky", the terms don't apply to SATA bus/ controllers.

    You have two independent bus to a single controller.

     

    It could be the presence of the original drive or the remnants of the PRAM contents is that which is interfering.

     

    Could it be a connection issue? Maybe the connector likes the old drive better....

     

    To be clear about your issue, the SSD works in bay 2 but not in bay 1? And the original drive works in bay 1?

     

    Is the SSD recognized when it is the only drive installed?

     

    Does a PRAM reset "wake" the system into recognition?

  • BitterCreek Level 1 Level 1 (100 points)
    Currently Being Moderated
    Feb 16, 2013 6:08 AM (in response to BDAqua)

    All drives on the market for the last 2 years are STAT-I compatible.

  • japamac Level 7 Level 7 (24,390 points)
    Currently Being Moderated
    Feb 16, 2013 5:19 PM (in response to DwainC)

    Well, it may simply be that the SATA controller doesn't treat the two bus as the same (one would think it should). The only difference should be the IO identifier assigned to connected devices.

     

    We do know that the G5 SATA controller is "based" on the SATA rev 1 standard (SATA 1.5 Gbps).

    I say "based" rather than "fully conforms" because it doesn't.

     

    This is likely the reason that the many reports of drives not being seen, incompatible, etc., occur with the G5; more "loose" application of the SATA standard rather than "strict" adherence to.

     

    After all, SATA was in it's infancy and, well, we all know that Apple has a thing about other peoples standards; they like to tweak things their own way.

     

    Anyhow, can you set the SSD as the desired startup/boot volume in System Preferences, restart and have the system boot to the SSD?

    If so, then the only issue is drive location, and that's really only a geographic issue of a couple of centimeters.

  • BDAqua Level 10 Level 10 (114,670 points)
    Currently Being Moderated
    Feb 16, 2013 6:03 PM (in response to DwainC)

    I've seen a few G5s here that could install to a faster SATA drive, & have it recognized as long as there was a slower SATA drive in it, & mostly if slower drive was in the 1st position.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.