4 Replies Latest reply: Feb 17, 2013 2:22 PM by miktoxic
miktoxic Level 1 Level 1 (5 points)

ok, so i'm a mac geek. i've got 2 g5s and a g4 quicksilver in the closet. i live in an apartment building and the other day someone had left a g4 in the community area up for grabs. it's a lot nicer than the g4 i have in the closet and it has some interesting software installed on it that i've never even heard of before. the person was obviously a professional photographer because of the software and the amount of personal info he left on the HDs.

 

well anyways i went ahead and deleted all of his personal stuff and all of the freeware and trial software he had on the dock. but here's the prob: i want to install some of my own personal software onto this computer that i have license to for multiple installs. but what keeps getting in the way is the fact that he was the admin account user (actually there are 2 accounts, one for him and another for someone else) and to install or make any changes the admin account adminstrator pops up and asks for the password of course of which i have no idea.

 

i've looked on the web and there are posts of people after rebooting holding the command and s keys down and getting into the initial bootup code. but they always show their code as reading

 

:/ root#

 

well mine reads

 

localhost:/ root#

 

and it won't allow me to follow the code instructions given by the posters.

 

and i don't have an old 10.4 install disc to boot to. what i do have is a 10.2 disc which i tried to boot to by holding down the c key while booting but it keeps going to the startup screen with the 2 account users window.

 

anybody got any clues to what i can do? any help would be greatly appreciated!

 

thanks. -tim.


g4 and g5, Mac OS X (10.5.5), os 9.2.2
  • 1. Re: reset admin password w/o discs?
    BDAqua Level 10 Level 10 (116,470 points)

    What happens when you hit enter at that prompt?

  • 2. Re: reset admin password w/o discs?
    miktoxic Level 1 Level 1 (5 points)

    at the prompt of the account login window there are 2 users i can just hit either one which will take me to 2 different windows with different wallpapers and items in the dock.

     

    if you are talking about hitting enter after booting to the startup code it just keeps going to

     

    localhost:/ root#

     

    thanks for your reply!

  • 3. Re: reset admin password w/o discs?
    Texas Mac Man Level 8 Level 8 (45,790 points)

    Here's the instructions if you have the discs.

    Mac OS X: Changing or resetting an account password

    http://support.apple.com/kb/HT1274?viewlocale=en_US

     

    Changing your administrator password

    http://docs.info.apple.com/article.html?path=Mac/10.4/en/mh655.html

     

    Here's one method to reset the password without the install disc:

     

    1. boot computer and hold the "apple" key and the "s" key.

    2. wait for terminal show

    3. release keys

    4. type without the quotes: "/sbin/mount -uaw"

    5. press enter

    6. type without the quotes: "rm /var/db/.applesetupdone

    7. press enter

    8. type without the quotes: "reboot"

    9. press enter

     

    This will let you create a new admin account when you reboot your computer.

     

    Also, without the discs, look at Mac OS X Tip - No Password, No Root, No CD? No Problem.

    http://www.macobserver.com/tip/2003/06/16.1.shtml

     

    Here is a way to get around not knowing the admin password on Macs.

     

    To reset your OS X password without an OS X CD you need to enter terminal and create a new admin account:

     

       1. Reboot

       2. Hold apple + s down after you hear the chime.

       3. When you get text prompt enter in these terminal commands to create a brand new admin account (hitting return after each line):

              * mount -uw /

              * rm /var/db/.AppleSetupDone

              * shutdown -h now

       4. After rebooting you should have a brand new admin account. When you login as the new admin you can simply delete the old one and you’re good to go again!

     

     Cheers, Tom

  • 4. Re: reset admin password w/o discs?
    miktoxic Level 1 Level 1 (5 points)

    thanks tom! i already had tried your second method the

     

    mount -uw /

     

    but that (i think) only works when you have as a precursor on the code line

     

    :/ root#

     

    i can't get my code to appear like that. it comes up as

     

    localhost:/ root#

     

    i'll try the other.

     

    thanks everyone for your replies!