Skip navigation

My iMessage still says "Waiting for activation..."

974704 Views 518 Replies Latest reply: Mar 19, 2014 9:23 AM by iscast RSS Branched to a new discussion.
  • Mani196 Calculating status...

    My imessage was'nt working for few but when i topped up my balance its working perfect  

  • Turk123 Calculating status...

    Hi, i have just bought an iPhone 3gs on the Orange network, and had a Orange contract sim from a blackberry, i have had this problem since i got it, it doesn't allow me to add a phone number or have an option too. it also doesn't activate the iMessage properly... what do i doooo?

  • husain52 Calculating status...

    Hi,

     

    I am from India and i am using Iphone 4.

     

    My problem is iMessage says "Waiting for activation" but for selected iphone users i am able to send iMessage but for few people i am not able to send who are using iPhone 4 and they are able to send iMessage to the numbers whom I am able to send.

     

    So any body facing same problem where selected iphone4 you are able to send but not to all?

  • Cameramen Calculating status...

    For those of you who are facing this issue in India (specifically Vodafone).

     

    Vodafone servers have an update, so turn both imessage and facetime off > reset your network settings > and then activate with Wifi or 3G. This is working and should activate well within 2 mins

  • Schuff Calculating status...
    Currently Being Moderated
    Feb 2, 2013 11:24 PM (in response to Cameramen)

    Even this is not working for me. I have raised a complaint to the high level authorities of Vodafone India. They've asked for 2 days and promised me to revert back with a solution. Lets hope for the best!

  • Pilot787 Calculating status...

    And it works.
    Now this is what happened: My network provider asked me to email my phone number to them two days ago. Today when I turned on my cellular data and the 3G, my phone went to No Service. Then I decided to restart my phone and turned on the iMessage and Facetime again, after 2 minutes iMessage and Facetime got activated. I tried the same for my wife's iPhone5 and it works.
    Looks like some one on the network provider side did the reset on my account after they received my phone number.

    So in my case, it wasn't my phone or my settings, it has to do with the network provider.

  • sumeetmulani Calculating status...
    Currently Being Moderated
    Feb 3, 2013 11:20 PM (in response to Cameramen)

    Read http://www.bgr.in/news/how-to-get-imessage-facetime-working-on-your-iphone-on-vo dafone-india/ . You can enable iMessage and FaceTime by manually sending an SMS to the UK number used for activating these services.

  • techfreakz Calculating status...

    my two cents worth.

     

    Ported my number from Vodafone to T-Mobile (UK) and imessages and facetime stopped via phone number. They both worked via email.

     

    I tried absolutely everything - bar a factory reset and clean install. even editing the carrier plist files. Nothing worked.

     

    Today phoned T-mobile - level one support said try the usual phone off/on etc. As expected didn't work. They scheduled a call back to speak to level two escalation team - he said check my number in phone to see if it started +44 and it was set as +44 not 0 as I had left it after many different tries (+44/0/0044).

     

    I don't know what they done at their end but instantly I checked imessages and facetime (as advised) both were now activated for use with mobile phone number. Tested and working 100%.

     

    My suggesstion is stop trying anything and speak to your carrier first.

     

    I must also say t-mobile customer service was fantastic.

  • john_doyle Calculating status...

    for those still encounter this issue..

    you can try this..

     

    turn off Wi-Fi (Settings>Wi-fi)

    turn off iMessage and Facetime (Settings>Messages and Settings>Facetime)

    enable Restrictions (Settings>General>Restrictions)

    make sure to allow Facetime, allow changes in Contacts and allow changes in Accounts

     

    restart your phone

     

    turn on Wi-Fi (Settings>Wi-fi)

    turn on iMessage and Facetime (Settings>Messages and Settings>Facetime)

     

    this should enable your iMessage and Facetime

     

    *you can disable Restrictions if you have this feature disabled before


  • AliSaid Calculating status...

    I think I have found the solution...

     

    switch off imessage on all of your other devices , ie Mac , iPad , IPod...etc.

     

    then enable iMessage on iPhone.  you will see the activation successful stratight away.

     

    Cheers,

  • Schuff Level 1 Level 1 (0 points)

    Okay. I have finally found this solution for Vodafone India. I had a word with the Vodafone executives and they were aware of the situation. They told me they had finally fixed the problem but it was still not working for me. So here's the final fix which I discovered.

     

    1) Sign out of your Apple ID from every app (iTunes, Game Center, iMessage, everywhere)

    2) Reset your network settings

    3) Go to iMessage and turn it 'ON'

    4) Wait for a few minutes and voila!

    Both iMessage and FaceTime gets activated after a few minutes.

     

     

    For those who still can't get it activated.

     

    1) Activate iMessage with your Apple ID.

    2) Download 2-3 apps from your iTunes.

    3) Now, complete all of the steps above after 1 day.

     

     

    If you still can't get it activated, Send a text 'activate imessage' to +445773142076

     

     

    I think these steps will activate iMessage for Vodafone India subscribers.

  • Werdbooty Calculating status...

    This totally worked for me. My problem was that I didn't have an active cellular data plan, and I stupidly turned off my iMessage because it said "activation failed" and told me to try turning iMessage back on. When I did, I got the dreaded "Waiting for activation..." Followed John's steps as he outlined and when I tested, everything was a go. Good stuff man, thanks.

     

    turn off Wi-Fi (Settings>Wi-fi)

    turn off iMessage and Facetime (Settings>Messages and Settings>Facetime)

    enable Restrictions (Settings>General>Restrictions)

    make sure to allow Facetime, allow changes in Contacts and allow changes in Accounts

     

    restart your phone

     

    turn on Wi-Fi (Settings>Wi-fi)

    turn on iMessage and Facetime (Settings>Messages and Settings>Facetime)

     

    this should enable your iMessage and Facetime

     

    *you can disable Restrictions if you have this feature disabled before

  • threepyes Calculating status...

    this worked for me with iphone 5 on 6.1.2

    Turn off imessages

    turn of face time

    send a text message to 49988 with the words activate imessage

    restart phone

    wait a few mins turn imessage back on

    turn facetime back on

     

    if that dont work try same thing but send text to +011447786205094 with the words activate imessage

     

    not sure which number worked for me as i tried both and after 2 days of trying everything else this finally did the trick. Hope it helps someone else to. fyi im in canada

  • MiguelPestana Calculating status...

    Since I was all day around this matter I'm giving you my 2cents. I had both the greyed out cell phone number (unchecked) and the waiting for activation problem. Got them both FINALLY solved.

     

    First: call your provider and ask if you have any internacional sms blockings, if so unblock them.

     

    Second: make sure you have enough money on you cell phone to cover for, at least, two internacional sms's.

     

    Then follow the steps written by SissyRibbons(don't skip any step for your own sake).

     

    You'll sort it out in 5 minutes.

    Cheers.

    SissyRibbons original post:

     

    Nov 19, 2012 8:54 PM (in response to MartinF123)

     

    Hey you guys. After several stressful hours,I found a solution (hopefully it will also work for you)

    I currently have iOS Version 6.0.1, but this should work for everyone

     

    After hours of trying several methods to fix your iMessages from different forum websites, i mashed all methods together.

    This all started when i accidently hit "iMessage" and turned it OFF, then it was not able to turn it back on using my number, but instead it was giving my email address for texting, or just giving regular text.  Hopefully this will work for you. Please read throughout all directions in order

     

    At this time, make sure your iMessage and Facetime are BOTH ON ( if you cant find these two options, skip a few steps down and it will tell you how to get to there)

     

    Before we start, BE SURE YOU HAVE A VALID "APPLE ID"


    1. Make sure your Date,Location, and Time are correct according to your time zone and location.

    Date/Time:

    • Go into "Settings"
    • Find and enter the "General" Tab
    • In the General Tab, find and enter the "Date and Time" tab
    • Turn OFF the "Set Automatically" ---- then. manually change the "Time Zone" to where you are currectly located" OR nearest location  (e.g. -  I am located in "Richmond CA," but the time zone I am checked in is "Cupertino CA(15 minutre drive away," So no big difference) ----Dont try and find me creepers, im a serial killer who rides a Donkey, serious business.
    • Turn "Set Automatic" back ON, (If it automatically find the closest city near you, no biggie)
    • End of Step

    Location: iMessages

    • Go into "Setting"
    • Find and enter the "Messages" tab
    • Scroll down and enter "Send & Receive"
    • Click on your Apple ID:
    • Click on "Change Location"
    • Make sure your "Region" is accurate to where you are located"
    • End of Step

    Location: Facetime

    • Go into "Setting"
    • Find and enter the "Facetime" tab
    • Click on your "Apple ID"
    • Click on "Change Location"
    • Make sure your Location is accurate
    • End of Step

    Okay, Now for the goodies, not too much though, might cut your tongue.  Step one: Sign out of your Apple ID.

    • Find and enter your "Store" app ( where you download all your apps for your iPhone), select the "Featured" category located at the bottom left of the app.
    • Scroll down on the page, you should see a tab where it shows your email Apple ID address. - click on it and Sign Out.
    • If youre already signed out, SIGN IN AND BACK OUT AGAIN
    • End of Step

    Step two: Turn off Wifi.

    • Go into "Settings"
    • Find  and enter the "Wi-Fi" tab,
    • Turn OFF Wi-Fi
    • End of Step

    Step Three: Enable then Disable Restrictions

    • Go into "Settings"
    • Find and enter the "General" tab
    • Find and enter the "Restrictions" tab
    • If  Restrictions are already disabled-----Enable it.
    • It will ask you for a "Restrictions Password" (I put the same code i use to log into and unlock my iPhone)
    • After you Enable it ---- DISABLE IT again, so that every tab is "OFF" and greyed out, unable to be clicked.
    • End of Step

    Step four: Turn off iMessage

    • Go into Settings
    • Find and enter the "Messages" tab
    • Turn OFF iMessages
    • End of Step

    Step Four: Turn off FaceTime

    • Go into "Settings"
    • Find and enter the "Facetime" tab
    • Turn OFF Face Time
    • End of Step

    Step Five: Reset Network Settings[NOTE: This will NOT erase contacts or any of the naked pictures you take of yourself/ Personal information, ex. Music, Schedules, or your only Girlfriend Siri (Doesnt count if youre a woman, Men, dont deny it, my Siri forced me to be her Husband :'( ]

    • Go into "Settings"
    • Find and enter the "General" Tab
    • Scroll Down and enter the "Reset" tab
    • Click on the "Reset Network Settings"
    • It may or may not ask you for a password, just use the same password again you use to get into your iPhone
    • ::Mr. T Voice:: PRESS THE RED BUTTON FOO!
    • End of Step

    After you pressed "Reset Network Settings" Your phone should have automatically restarted. Now for the Finishing Steps. Now that your phone has restarted, You must do the "Cha Cha Slide" and "Hokey Pokey" to induce a magical spell onto your iPhone. Just kidding, but try it, you'll make a fool of yourself and relieve some stress from all the researching you have been doing to fix this problem.  It's Okay if you didnt, im still your friend. =D NOTE: DO NOT SIGN INTO WIFI, From now on until your "iMessages/Facetime" Works, You should be running on "3g or 4g" internet
      Step Six: Sign in into your Apple Store

    • Find and enter your "Store" app ( where you download all your apps for your iPhone),
    • Select the "Featured" category located at the bottom left of the app.
    • Scroll down on the page and SIGN IN
    • End of step

    Step Seven: Sign into iMessages (MAKE SURE YOUR WI-FI IS STILL OFF or "Not Connected"!! and running on "3g/4g")

    • Go into "Settings"
    • Find and enter the "Messages" Tab
    • Turn ON "iMessages" (It may or may not ask you to sign into your Apple ID, just sign in whenever they ask you to.  OR there might be a tsb where it will say something about "You need to sign into your Apple ID, blah blah blah, something along those lines, Click it and Sign in)
    • Let it load ( loading times may varry, from five minutes to 1 and a half hours, keep checking in all while you DO NOT SIGN INTO Wi-Fi!)

    IMPORTANT! - Now, when i turned ON iMessages, IT FAILED THE FIRST.. or second time(cant remember), KEEP TRYING! It should turn on after three or four tries. Now do not toggle the On&Off button during the proccess of it loading because it will restart the whole loading process. Just wait until it says "unsuccessfull" to Turn off iMessages and on again. HOPEFULLY when your iMessages is turned on, Step Eight: Repeat step: Seven,

    • For your Facetime.  That also failed once for me before it started to work again.

     

     

    After both iMessages and Facetime are working, you are now free kiss a baby or Pet(Gold Fish, Husband and Wife included) on the cheek out of joy....but put him him/her/it down, youre scary looking and might make the baby/pet cry

     

    You are also free to sign back into Wi-Fi

     

    I hope this works for you. Enjoy your day and help a random stranger out.

     

    If it worked and you feel generous, Copy Paste this into any Forum or Website (Eg. Yahoo Answers) so others can see and be helped.

     

     

    SissyRibbons OUT!

     

    ^Best nickname ever.

  • DanielSG93 Calculating status...

    I live in Mexico and have an iPhone 5 iOS 6.1.2; I updated my Telcel 5.0 3G SIM for the new 6.1 LTE SIM, after I changed it I had no iMessage any more, when I tried to reactivate the service it shows "waiting for activation. I´ve tried all "fixes" on the web and still no solution!! I also put back my old SIM and nothing..... I think its Apple´s server problem that you cant submit the same telephone number twice!! Please help!!

1 ... 28 29 30 31 32 ... 35 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (13)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.