Skip navigation

new macbook pro 2011 weak and dropping wireless connection

233314 Views 965 Replies Latest reply: Jan 7, 2014 3:13 AM by BananaMacintosh RSS
  • yozhbk Level 1 Level 1 (0 points)

    Well have to say, seems that ML fixed the issue ! I do not get any more drop pings while transfering files !

  • Relin Calculating status...

    I have a MBP 2011 running Mountain Lion and am getting a fair amount of WiFi drop out and ping drops in a corportate enviroment.  I have tested a MBA, and iPad and a Windows PC along side and the other devices are experienceing no drops at all.

     

    I have tried removing the WiFi networks from my keychain etc etc but still to no avail.

     

    Any other suggestions?  Its dropping every 3 mins or so and not reconnecting.

     

    Thanks

  • Relin Level 1 Level 1 (0 points)

    I have also reset the SMC and the PRAM but still have the same problem

  • Relin Level 1 Level 1 (0 points)

    Still having the same problems with WiFi dropping on my 2011 MBP running Mountain Lion, does anyone have any fix suggestions ?

     

    Thanks

  • grey33ad Calculating status...

    I've had issues with wifi three times, on both a MBP and MBPr.

     

    If you have access to the router settings, try to see whether the "WMM" option is turned on. If it is, turn it off. WMM prioritizes the internet connection so streaming gets priority --- but it doesn't work well with the macs I've had. I was having almost no download speed before that. Here's a reference: http://brikis98.blogspot.com/2012/02/got-slow-download-but-fast-upload.html

     

    If you don't have access, I also had success one time (after calling apple support) by adding a dollar sign $ infront of my password. I think there were some other instructions (which I posted on here about 60 pages ago) but that's easy enough to try.

  • Relin Level 1 Level 1 (0 points)

    I will try the password thing, unfortunatly this is in a corportate enviroment and i have no access or control to the infrastruture, i just know its not a problem for any PC or MBA users within the building

     

    On average i am getting drops every threee mins or so but if i ping a server spikes are a lot more frequent than WiFi disconnects.

  • grey33ad Level 1 Level 1 (0 points)

    The WMM stuff only affects Macs as far as I can tell. You could email your admin... sorry.

  • Relin Level 1 Level 1 (0 points)

    adding a $ sign to the password is not accepted

     

    will drop them a mail but doubt it will get anywhere, it USED to work fine but seems to have degraded over a period of 3 months?!?!?!

  • BYOH Level 1 Level 1 (20 points)

    Comparing WiFi performance on my Early 2011 13" MBP using Windows7 Ultimate Bootcamp seems to confirm that this is not a hardware issue but a MAC OS issue as others have also noted. MAC side is Lion updated to latest as of 11/13/2012.
    Issues that I am having on MAC OS  are intermittent drop outs disconnects and when running ATT speed test inconsistant readings for Download and upload speeds. When hooked up to Wired LAN cable though no issues.

  • BYOH Level 1 Level 1 (20 points)

    These are the test results MAC OS Versus Win7 The DL speed is most affected with the UL speed not as much most times as in this Pic it is normal.

     

    MAC ATT SpeedTst.jpg

     

    Win7 SpeesTst.JPG

  • rbpeirce Level 1 Level 1 (0 points)

    Hmm.  Just replaced a 2007 MBP with the latest model (retina display).  After a week I started to get very random upload and download speeds, sometimes disappearing entirely.  I called Verizon.  I changed routers.  I called Apple.  I took it into the local Apple store, where of course it worked perfectly.  I connected to the router with ethernet, where it woried perfectly. Then I tried my wife's MacBook, side-by-side, and it worked perfectly while my new MBP hung.

     

    In researching this I found the problem goes back years but only affects some machines.  However, it is difinitely the MBP connecting over WiFi.  I don't know if Apple is working on this.  I would post a bug report but by now I am sure they have many.  I eagerly await a solution.

  • Csound1 Level 7 Level 7 (32,495 points)

    Delete your existing WiFi connection and create a new one.

  • BYOH Level 1 Level 1 (20 points)

    I have done that and still the problem persists. I have no issues as well with my Hp Notebook it's just the MBP.

  • rbpeirce Level 1 Level 1 (0 points)

    I may have found my probloem but it will take a few days to be sure.  I got a "motormouse" for Christmas and it operates at 2.4 Ghz, same as my wireless router.  I went back to my old mouse which must operate at a different frequency and so far, so good.

     

    I have a number of 2.4 Ghz devices, mostly phones, but none of them ever caused problems.  I think proximity is the key.  The nearest phone is 2' away but the new mouse transmitter plugged into a USB port on the computer.

     

    If you are having this problem, try disconnecting all your 2.4 Ghz devices, and I mean all, to see if it goes away.  If it does, you may be able to identify the problem by reconnecting one at a time and testing.

     

    Of course, if the problem doesn't go away this will have been of no help.

  • cmd11111 Calculating status...

    I am also having this problem. I replaced my Acer Timeline X, which crashed, with a brand new Macbook Pro 13 inch. I've had it for four days, and I am constantly losing connection.

     

    I drove all the way to the Apple Store in the mall, and talked to an employee at the "Genius Bar" (groan). He said it connects fine in their store, so there isn't a problem with the computer. The problem is with my router. My router is only three years old, and none of the other 3 computers are having a problem, but he was adamant.

     

    So, I went and got an extender, and have been monitoring connectivity with iStumbler. I switch back and forth between the original connection, and the "extended" connection. They both have the same amount of "juice" (50-60%) according to iStumbler. Which isn't surprising, because I'm in the same freaking room as the original router and the extender.

     

    I am having to turn the wifi off and on anywhere from every 3 minutes to every 20 minutes. Sometimes, the wifi will go out, but iStumbler shows no change, which I really don't understand.

     

    I am going to have a support call with Apple. Perhaps I need a new router, and should return the extender. However, I will be quite irate if I have to spend another $100 for a new router on top of the premium price I paid for this laptop. Considering that my computer, which crashed last week, never had this problem. And if I get a new router, I will have a new connection, which will require another service call for my house alarm, which is another $100.

     

    So, so far I've paid $200 because I bought an Apple. Maybe I should return it and get another Acer?

Actions

More Like This

  • Retrieving data ...

Related Articles

Bookmarked By (22)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.