Skip navigation

Updating iPhoto failed

203 Views 2 Replies Latest reply: Feb 18, 2013 12:54 AM by Lauren.Kopf RSS
Lauren.Kopf Calculating status...
Currently Being Moderated
Feb 17, 2013 9:40 AM



I have tried uploading the new update but it has failed. It requests to go to Purchases page but it says it has failed and to go to the page again.


I can not open the program to view photos.


Can anyone please help?


Thanks in advance,



MacBook Pro with Retina display, OS X Mountain Lion (10.8.2)
  • Old Toad Level 10 Level 10 (112,985 points)
    Currently Being Moderated
    Feb 17, 2013 12:15 PM (in response to Lauren.Kopf)

    What version of iPhoto did you try to update to the latest version? Did you purchae iLife 9 from the App Store originally?  If so try moving the current iPhoto to the Desktop, go to the App Store, log in with the Apple ID you used to purchase iPhoto 9 originally, go to purchase and try again.




More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.