Skip navigation

Library doesn't play MOV-files on one computer, no problems on another.

907 Views 12 Replies Latest reply: Feb 18, 2013 12:21 PM by 916hyp RSS
916hyp Calculating status...
Currently Being Moderated
Feb 9, 2013 8:56 AM

I have my Aperture 3.4.3 library on a TimeCapsule.

 

A few days ago I suddenly got a note that there was a problem with the library and it wouldn't open. This was on my principal computer. After a while (repairing library and reparing permissions) I got it to open.

 

The problem is now that I can't view clips (MOV-files). I can see the thumbnail just fine in the Browser and the Split View, but not the clip itself, ie in the Viewer. And I can't start the clip.

 

When I look into the library itself I can find the file and it plays in VLC.

The wierd thing is that the whole library also plays and behaves normally on my second computer. Including all clips!

 

Any ideas on what to do?

 

The only thing I have done to this computer recently is the mounting of a SSD-drive (restored from a copy in TimeMachine).

 

I have restarded the computer.

I have checked the disk for permission-problems.

 

I guess the problem lies in the program itself on this computer? (Since there are no problems with my other computer).

 

Please?

Aperture 3, OS X Mountain Lion (10.8.2)
  • Frank Caggiano Level 7 Level 7 (22,795 points)

    If the library works OK on the other computer then yes that would seem to rule out a library problem for now.

     

    BTW both computers are running the same OS and Aperture versions right? If not stop here and post back the OS and Aperture versions on the two machines indicating which belongs to the working system.

     

     

    I would look at the last thing you did before you started having problems on this computer:

    The only thing I have done to this computer recently is the mounting of a SSD-drive (restored from a copy in TimeMachine).

    you'll need to explain this in more detail. Is this now the system drive?  As a test I would go back to the configuration before you made this change and see if Aperture works. If it does then you know it is the problem has something to do with the change.

  • Frank Caggiano Level 7 Level 7 (22,795 points)

    Again if the problem occurred after making the changes you made you should try to get back to the configuration that worked.

     

    Is the SSD installed as the internal root drive? If so then wipe the disk starting over but this time don't download and run the program you got from the web.

     

    Other things to try to isolate the problem:

    What happens if you make a new Aperture library and import a movie into it, does it play?

    What about if you make a new user and run Aperture as the new user and import a movie, does it play then?

  • Frank Caggiano Level 7 Level 7 (22,795 points)

    Best I can think of right now is to have a look in the Console logs and see if anything shows up.

     

    Open the Console (/Applications/Utilities/Console), make sure All Messages is selected in the lefthand column and then in the upper righthand corner, in the search box, try entering Aperture and see what comes up.

     

    Not sure why Aperture is the only thing not playing the video, especially if iPhoto is. It would seem to have something to do with the changes you made but perhaps that the problem appeared now is just a coincidence.

     

    Maybe the logs will give a clue.

  • Frank Caggiano Level 7 Level 7 (22,795 points)

    Ok this problem appears on some systems if a cache file is missing from the OS.

     

    Look in /Library/Caches/ for a file called com.apple.xpchelper.cache If it is missing on the system that is not working look in the system that is.

     

    If the file is missing on the bad system and there on the good system you can just copy the file over. 

     

    The other thing you can try to recreate the file i it is missing is to open a terminal window and enter

     

    sudo /usr/libexec/xpchelper --rebuild-cache

     

    some users have reported that that works. I can;t vouch for it but one one has complained that it caused any harm to their system so it is worth a shot if you can;t copy the file from your other system.

     

    A reinstall of the OS should also fix the problem.

     

    Message was edited by: Frank Caggiano

  • Frank Caggiano Level 7 Level 7 (22,795 points)

    Glad its working.

     

    I just realized I entered the wrong path for the cache file. Should be

     

    /System/Library/Caches

     

    If you look there you should see the file.

     

    regards

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.