2 Replies Latest reply: Feb 18, 2013 2:34 PM by thermitnomade
thermitnomade Level 1 Level 1 (0 points)

I'm looking for help. Easy for someone with knowledge, I think. I have a new Iphone5 and it is not possible to connect it to Itunes on my IMac, because the Mac runs on 10.5.8

Which system-upgrade is needed? But: I'm using the first Creative Suite, this is very important. I can't upgrade CS, not know, it's too expensive for me. Does the CS work with new systems?

 

<Edited by Host>


iMac, Mac OS X (10.5.8)