Skip navigation

Google Calendar delegates being listed twice

6220 Views 26 Replies Latest reply: Feb 7, 2014 6:50 AM by Anton Danilchenko RSS
  • MichaelTorfs Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 4, 2012 6:57 AM (in response to Geoff Fitch)

    Same problem here... Very annoying...

  • nei0angei0 Calculating status...
    Currently Being Moderated
    Dec 4, 2012 12:50 PM (in response to MichaelTorfs)

    add me to the list!!!! what a stupid problem

  • opfeifer Calculating status...
    Currently Being Moderated
    Dec 4, 2012 1:27 PM (in response to Geoff Fitch)

    Same problem here, with Snow Leopard. Duplicate Calendars keep comin' and goin'.

  • Gordon Craig Calculating status...
    Currently Being Moderated
    Dec 4, 2012 6:14 PM (in response to opfeifer)

    Same problem here, on two different Macs running Mountain Lion.  Rather annoying.

  • Csound1 Level 7 Level 7 (32,255 points)
    Currently Being Moderated
    Dec 4, 2012 6:41 PM (in response to opfeifer)

    opfeifer wrote:

     

    Same problem here, with Snow Leopard. Duplicate Calendars keep comin' and goin'.

    You mean "Same problem here, with Google. Duplicate Calendars keep comin' and goin"

  • swellshark Calculating status...
    Currently Being Moderated
    Jan 23, 2013 6:02 AM (in response to Geoff Fitch)

    Hi all

    Having spent what feels like years of my life trying to get rid of duplicate calendars, I have finally found something that may help:

    It seems Google no longer use delegation but it happens automatically if you use an account preference of google and not your email account.so...

     

    I went into https://www.google.com/calendar/syncselect and checked that the calendars I wanted were correct.

     

    Then into ical, this bit taken from setting up a new iCal Google Calendar

    1. Open Apple iCal
    2. In the toolbar, click Calendar, then Preferences
    3. Click the Accounts tab
    4. In the accounts pane on the left, click the + button to add an account
    5. Enter the following information:
    • Account Type: Google
    • Email Address: Enter the email address that you use to log in to Calendar. Make sure to include the '@domain.com' portion (which is @gmail.com for Gmail users) in this section.
    • Password: Enter the password for the email address you listed above.

     

    I had previously had an email account CalDav and therefore delegation duplicates too.

     

    If you previously synced additional calendars using Delegation, you have to remove those settings to prevent duplicate events:

    1. In the iCal toolbar, click Calendar, then Preferences
    2. Click the Accounts tab
    3. Select the correct account in the left pane and click Delegation
    4. Deselect all checkboxes for your additional accounts

     

    Now instead of having my email calendars, cloud and delegation, the delegation ones are gone and I have google showing but No duplications, hurrah!

  • swellshark Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 23, 2013 6:06 AM (in response to Geoff Fitch)

    PS I forgot to add, once you have the google account running don't forget to go back into iCal preferences and delete the original email account in Calendars or you will definitely get duplicates!

  • Gordon Craig Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 23, 2013 11:27 AM (in response to swellshark)

    Thanks!  That seemed to do the trick. 

  • MrCraig Calculating status...
    Currently Being Moderated
    Jan 25, 2013 9:25 AM (in response to swellshark)

    Thanks, Swellshark. The delegation thing was my problem.

  • m_westmoquette Calculating status...
    Currently Being Moderated
    Feb 19, 2013 3:12 AM (in response to swellshark)

    Thanks for that advice. I've done as you say, and indeed I now no longer have any duplicates and things look ok. However, I now have the problem that new items added will only be accepted into my default google calendar. If I attempt to change the calendar under which they're listed (e.g. to "work"), after updating with the server they're automatically switched back to the default calendar. The only work around I've found is to go to the google calendar webpage and change them there - clearly not a great solution.

     

    Just now I tried switching the delegates back on (under Preferences, Delegation) - all the duplicates re-appear - and then  changing the calendar for a random entry to one of the delegate calendars. That works, even after updating with the server. Again obviously not really a solution though.

     

    Does anyone else find this? Is there a way around this?

  • bebopper Calculating status...
    Currently Being Moderated
    Feb 19, 2013 11:07 AM (in response to m_westmoquette)

    Google made an unannounced change to their calendar services back in mid November 2012, apparently to eliminate the need for Delagates to display shared calendars. They introduced bugs along the way and caused endless problems and headaches for iCal/Calendar users far and wide. It took them about a month to fix the biggest problems (duplicates, non-stop alerts, 404 errors), but a few problems remain (can't set alerts, can't schedule events on shared calendars).

     

    Dumping the iCal cache files helps settle things (there are several). Things seem to work a little better in Calendar v6 (Mt. Lion) than earlier versions. BusyCal 2 on Mt. Lion is also much better. iOS calendars seem to be unaffected (possibly because iOS and BusyCal don't have the delegates feature.) Using Google Calendar on the Web is an obvious work-around to the whole mess.

     

    You can see the whole sturm und drang on this long, endless thread:

    https://productforums.google.com/forum/#!msg/calendar/AWJSWllOt9Y/dy_iwDMHQ28J

     

    Not a pleasant experience to say the least, especially with zero communication and support from Google. Hope this sheds a little light on things.

     

    c'est la vie

  • Anton Danilchenko Calculating status...
    Currently Being Moderated
    Feb 7, 2014 6:50 AM (in response to swellshark)

    Oh, yes! I need just to deselect all calendars on Delegation tab. It's now have not duplications!!!

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.