Skip navigation

Unable to Connect to Network Printer

5437 Views 43 Replies Latest reply: Apr 14, 2013 8:05 AM by Samir Sogay RSS
  • PAHU Level 6 Level 6 (14,400 points)
    Currently Being Moderated
    Feb 20, 2013 3:39 AM (in response to DhruvC)

    Now that you have it configured exactly the same as Windows and it still doesn't work it must be the OS X driver in combination with this 2750U. The log is showing that the driver is not getting the feedback it is expecting. This is often the case when the USB port does not support bidirectional communcation.


    If the printer supported Postscript or PCL then you could at least try one of the Generic drivers included with OS X. But since the driver is using a Samsung proprietary language, then you are stuck with having to use this driver and the limitations it has.


    Oh well. We gave it our best but I think we've been beaten by inferior products.

  • PAHU Level 6 Level 6 (14,400 points)
    Currently Being Moderated
    Feb 20, 2013 3:58 AM (in response to DhruvC)

    I think it is the driver in combination with the USB port of the 2750U.


    As for the Queue name, I feel it is correct. Windows is using this and the 2750U web page confirmed the queue name that Windows is using. As for the queue from the direct USB connection to the Mac, this information is obtained from the printer. Note that CUPS does not like spaces so it inserts the underscores. If you wanted to remove this printer and add it again using the same name that the direct USB connection uses, then do so. It's worth a try at this stage.


    As for the driver, if this is not the driver you were already using then by all means try it. Samsung may have made it more compatible with 3rd party print servers...

  • PAHU Level 6 Level 6 (14,400 points)
    Currently Being Moderated
    Feb 24, 2013 3:06 AM (in response to DhruvC)

    DhruvC wrote:


    PAHU, any reviews on the error message: ipp-missing-printer-is-accepting-jobs?

    If you look at the cups error log, you can see this exact line and others mentioned. I think this all comes down to the information being sent by the driver but it is not being responded to.


    To test the driver theory, remove this printer and add the printer again using the CUPS web interface. But this time instead of selecting the Samsung driver, select the Generic Postscript driver. With this new printer I believe you will get a different set of errors in the log - or maybe none. Note that I don't expect the job to print but it could print several pages of rubbish (Postscript code).

  • Samir Sogay Calculating status...
    Currently Being Moderated
    Apr 5, 2013 3:39 PM (in response to DhruvC)

    You can refer to my blog about enabling mac os x for usb printing. I have been able to print from my macbook to the printer connected to Dlink router but the only problem is that I have to reboot my router before printing. Hope some expert on printers can comment to rectify this issue. May be it has to do with the fact that these printers are supporting just one way communications.


  • greg sahli Level 7 Level 7 (23,470 points)
    Currently Being Moderated
    Apr 6, 2013 6:41 AM (in response to PAHU)

    PAHU was right all along. The Samsung driver includes its own USB-access driver, and so it can't talk to the OS X/CUPS software for network printing.

    (did you notice that the other two people were talking about other hardware combinations? Some routers have software that makes the remote USB connection look local - did you install any software for the router on your Mac, Ashcroft?)

    You'll have to experiment with this open source driver: g-gdi#Printers

  • greg sahli Level 7 Level 7 (23,470 points)
    Currently Being Moderated
    Apr 14, 2013 6:24 AM (in response to DhruvC)

    By experiment, I mean - install the Samsung set, which requires all three parts to be installed. That includes multiple models.

    Once installed, Add the printer in Print & Scan and choose model ML1610 (what I'd do, at least). If it isn't quite right, try ML1710. Etc.

  • Samir Sogay Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 14, 2013 8:05 AM (in response to DhruvC)

    One thing I am definite about is that it will only work on http://ip-address-of-router:631/printers/name-of-printer-set-on-dlink. If you know about networking, you can port scan your router and see that port 631 (port for ipp) is open and port 9100 (jetdirect) is not open which means it is not active. This is valid just for DLink router. Some routers support ipp and some support jetdirect. Also, there is no need to put the queue because it will take it from the "/printers/name-of-printer-set-on-dlink" from the url. This I have validated by sniffing the traffic sent by the Mac to the Router over the ip network. The only thing you need to check is the driver.

1 2 3 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.