Skip navigation

IOS 6.1.2 Update Still Wifi not remembering settings

8031 Views 16 Replies Latest reply: Feb 27, 2013 9:05 AM by octavmih RSS
1 2 Previous Next
YouWhat Level 1 Level 1 (0 points)
Currently Being Moderated
Feb 19, 2013 1:51 PM

Have just updated my iPhone 4s to IOS 6.1.2 hoping that the wifi issue where it has been forgetting the password on reset has been resolved, only to find out that it is still an issue.


When is apple going to sort this issue out? I can't be the only user getting this issue.

iPhone 4S, iOS 6.1.2, WIFI Amnesia
  • amy_lou Level 4 Level 4 (1,550 points)
    Currently Being Moderated
    Feb 19, 2013 2:20 PM (in response to YouWhat)

    What is the name of your home wifi network? If it's generic like Netgear or Belkin, if you change the name of the network to something more unique, you shouldn't have the issue


    You can also try accessing the network by connecting to it via the 'other' option under the 'choose a network' menu. Make sure you type the name of the network in the 'other' option exactly like it appears under the 'choose a network' menu

  • amy_lou Level 4 Level 4 (1,550 points)
    Currently Being Moderated
    Feb 19, 2013 3:28 PM (in response to YouWhat)

    That's completely fine that you feel that way, but this is not a portal to contact Apple. I have told you how I have seen the issue get resolved before. If all you wish is to complain at Apple about how messed up the update is, I suggest you do so here to have your voice heard, otherwise, this website is not an affective place to do so


  • Zoey1502 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 20, 2013 1:03 AM (in response to YouWhat)

    I have the exact same problem, exactly as you described it. Let me know if you find a solution, as there is not any other problem than with phone itself, not with the network setting or name, and there is also not any way to fix it - for more than 3 minutes! - by turning off the wifi or the phone or whatever

  • saidulsaidul Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 20, 2013 1:38 AM (in response to YouWhat)

    I am having similar problems.  Upgraded to 6.1.2 last night in the hope the wifi issue would be resolved.  Initially it was no improvement, but after 2 resets of my phone, I have an intermittent wifi connection. when not using the web browser app it seems to go to 3G, then when i start the broswer app, it picks up the wifi, but might lose it again midway through the session.


    I guess will have to wait for 6.1.3 :-(

  • christian_martin Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 20, 2013 2:13 AM (in response to YouWhat)

    I too am having the same issue, so annoying, IOS 6.0 fine, IOS 6.1 now my wireless network at home is buggered!!! sort this out.... how many times do i need to see the "unable to join wireless network" error.. I have 7 different devices that have no problem, my old 3GS does not have a problem, talk about going backwards!!! Now i really like Apple products however this all signing dancing iPhone 5 is not singing nor dancing i really need a fix for this... My data plan is getting a kick in the nuts! Apple you going to pay for this?? ? Doubtful

  • SamuelMei Level 1 Level 1 (0 points)


    How about 3G data problem in ios6.1?

    is it solved?



  • jla930 Level 1 Level 1 (85 points)
    Currently Being Moderated
    Feb 20, 2013 4:41 AM (in response to YouWhat)

    See if this works.  Go into Settings, then Wi-Fi, then touch the little blue arrow to the right of the name of your network.  Do you have settings for Auto-Join and Auto-Login?  If so, set Auto-Join to on, Auto-Login to off.

  • gus079 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 21, 2013 7:30 AM (in response to YouWhat)


    Same problem here,

    It recognize my wifi network, but I have to choose and retype the wifi password everytime in my 4S (6.1.1).

    My router is Cisco WRT120N and i didnt have any issue with iOS 5.1.1

    Any help??

  • tonerf Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 21, 2013 9:15 AM (in response to YouWhat)

    I have this problem as well! I havent had wifi capability since updating to 6.1.1 and had my iPhone 4 looked at and told there was no issue with the wifi connection/parts in the phone and that it was the software update.

    I updated last night to 6.1.2 hoping this issue would be resolved and it hasnt been!!
    my phone gets wifi right beside the router but thats it! if i move any distance more than a few feet away from the router it drops connection!



  • JROU Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 22, 2013 4:33 AM (in response to YouWhat)

    Same problem here in South Africa with a restaurant wifi. Tried all the tricks suggested in this stream, no luck after upgrading to iOS 6.1.2. Strange thing, my phone is a 32GB phone, my wife got hers 2 weeks after me, but a 16 GB phone, and it does not have the same issues after 6.1.2! Upgrade? So what is it then?

  • Zoey1502 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 23, 2013 10:23 AM (in response to YouWhat)

    My wifi was finally working, right after my previous post, a couple of days ago. But now it stopped working again, so I was trying to reset the phone (iPhone 4s iOS 6.1.1) a couple of times, while switching on and off the wifi in settings, but now it seems to be completely disabled and I cannot even turn it on! The key is just grey and cannot be pushed at all! Did it happen to anyone in here? Has anyone heard about that? I was searching for this, but all I found was a post of someone who put his phone in the freezer for 30 min. (Which sounds to me very weird I must say) and there were not any comments. Please!

  • JeaniceSkipper Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 25, 2013 3:49 PM (in response to YouWhat)



    I have iPhone 4s running 6.1.2 Everything worked great before the lovely update. My wifi did the same thing that everyone else's seems to be doing. It would not recognize my home router.


    Evidently, in the update, Apple changed how the "Ask to Join Networks" button operates. Previously, I didn't have to have the button toggled to on, my phone would just automatically lock onto my router. I have fought and fought with this update. I have done several "network settings resets". I have even restored my phone twice. I have tried every crackpot, and not so crackpot, suggestion on these forums and NOTHING has worked. I could go to settings and connect to the router each time I used the phone, but it would only stay connected for a few minutes.


    Today, I toggled the "Ask to Join Networks" button to "on", then opened Safari. My phone then asked if I wanted to join the network, I responed with join. My phone has been on wifi all day! I left home and came back several hours later, and FINALLY... my phone locks on automatically.


    Go to settings>, Wi-Fi>, toggle "Ask to Join Networks" button to "on". Then click on your router/network in the list.


    I realize that everyone's problems are not the exact problems I had, but maybe this will help some of you having problems.


    Good Luck!

1 2 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (1)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.