Skip navigation

Unable to log onto account server

534 Views 12 Replies Latest reply: Feb 20, 2013 11:50 AM by mnorthern RSS
mnorthern Calculating status...
Currently Being Moderated
Feb 18, 2013 7:07 AM

I recently setup a Snow Leopard server for my company (Our current server is the Early 2006 model and does not support ML). This server is supporting both Snow Leopard and Mountain Lion clients. We are currently using the server as a portal for users accessing our Promise RAID share, which is working well. They all have their own accounts.


I am now trying to bind computers to the server, so that they may use network login accounts. For some reason, the client computers are detecting the server, showing groups and users, and seems to be working fine, but I cannot log in with network accounts, I just get a window shake.


I ran an id on some usernames on one of the clients, and they all showed the user information, so they are definitely connecting to the server and retreiving authentication information. Why can't I log into a network account?

Xserve, Mac OS X (10.6.8)
  • Don Roedl Calculating status...
    Currently Being Moderated
    Feb 18, 2013 7:36 PM (in response to mnorthern)

    Hi MN, the workstations bind successfully to the server, but shaking window upon login attempt? If you login to the workstation as the local admin can you then mount the users home dir over AFP?

  • Don Roedl Level 2 Level 2 (210 points)
    Currently Being Moderated
    Feb 19, 2013 7:55 AM (in response to mnorthern)

    To mount the users home directory over AFP while logged in as the local admin, invoke the connect to server command, Enter the name or IP address of the server, and then enter the users name and password. The users home directory should then appear in the list of options.


    Two quick questions:

    How did you set up the user shares for each user? (by user shares you mean home directories, correct?)

    Are the user shares located on the same volume as the server operating system, a second volume on the same box, Or on another device?

  • Don Roedl Level 2 Level 2 (210 points)
    Currently Being Moderated
    Feb 19, 2013 8:39 AM (in response to mnorthern)

    Ok. Moving along......For the purpose of simple troubleshooting I would try this:


    Setup a 'test' account with the user home directory located on the Users folder on same volume as the operating system on the OD server. See if this account can login successfully and mount the test users home dir at login.

  • Don Roedl Level 2 Level 2 (210 points)
    Currently Being Moderated
    Feb 20, 2013 10:14 AM (in response to mnorthern)

    If login doesn't work with the most basic User folder then the problem is not just with the user homes defined elsewhere. That is what I wanted to know - you can't log in to the box period. How is your DNS setup looking? You have forward and reverse DNS set up, and lookups test out correctly?

  • Don Roedl Level 2 Level 2 (210 points)
    Currently Being Moderated
    Feb 20, 2013 10:36 AM (in response to mnorthern)

    You may find this information useful:


    To verify correct DNS configuration on a Mac OS X Server system, use the changeip command.

    Here is an example:

    $ sudo changeip -checkhostname


    Primary address     = 

    Current HostName    =

    DNS HostName        = 

    The names match. There is nothing to change.

    dirserv:success = "success" $

    This is the expected output for a host named at the private IP address You might see The DNS hostname is not available, please repair DNS and re-run this tool. or some other message as output from this command. However — if you do not receive that There is nothing to change. text in the output — then your DNS configuration has an issue; an unreachable DNS server, or a DNS configuration error.

  • Don Roedl Level 2 Level 2 (210 points)
    Currently Being Moderated
    Feb 20, 2013 11:41 AM (in response to mnorthern)

    "Will the machines still be able to authenticate with the Mac Server if they are using our Windows server for DNS?"


    Yes, it doesn't matter what box does the DNS. Have you tested one of the workstations to ensure that forward and reverse lookups to the SL server are working properly?


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.